ClubWRX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I own a 03' Bug Eye. She's been running kinda rough idling but drives pretty smoothly, I also have a small exhaust leak. So I was bored today and was kind of surprised to see what codes it threw. Any idea / comments / solutions??

P0102 Mass or Volume Air Flow Circuit Low input
P0113 Intake Air Temperature Circuit High Input
P0128 Coolant Thermostat ( Coolant Temp. Below Thermostat Regulating Temp.)
P0301 Cylinder 1 misfire
P0302 Cylinder 2 misfire
Po303 Cylinder 3 misfire
P0304 Cylinder 4 misfire
P0420 Catalyst System Effciency below Threshold (Bank 1)
P1086 Tumble Generator Valve #2 (LH) Position Sensor Circuit Low Input
P1092 Tumble Generator Valve #2 (LH) Malfunction (stuck open)



AHHH!
 

·
Premium Member
Joined
·
25,496 Posts
WOW... I would almost suggest fixing the exhaust leak, changing spark plugs, replacing fuel filter and cleaning maf sensor.. clear codes, run car and see what comes back
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
WOW... I would almost suggest fixing the exhaust leak, changing spark plugs, replacing fuel filter and cleaning maf sensor.. clear codes, run car and see what comes back
Hey thanks, I replaced plugs / sleeves and fuel filter check engine light still came back on with the misfire codes, haven't tried the maf sensor though...
 

·
Premium Member
Joined
·
25,496 Posts
You need to fix the gasket leak as well. Did you recheck your connections on the coil packs?
 

·
Premium Member
Joined
·
25,496 Posts
Might do a leak down and compression test to be safe..
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
You need to fix the gasket leak as well. Did you recheck your connections on the coil packs?
Actually no I didn't, ive been doing some research and similar problems happened to a couple of people and It was a center diff. issue for the both of them, they detected '' binding '' not sure what that is but whats the odds all 4 coil packs could be bad at the same time.
 

·
Registered
Joined
·
6,751 Posts
What mods does the car have? How many miles on it? How long have you had it, and how long have you been having issues?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
What mods does the car have? How many miles on it? How long have you had it, and how long have you been having issues?
The car has a HKS SSQV BOV, approximately 182k on the motor and tranny and i've owned it for almost 2 years, It has been throwing codes for a while a while probably for about a full year, and the idle isn't too bad it stays at about 500rpms but fluctuates and drops a little lower, never stalls out and runs smoothly while driving don't feel no hicups or anything.
 
1 - 9 of 9 Posts
Top