Subaru WRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So, I have had an issue with burning oil (1L between oil changes) for a solid 3-4 months now. I put it to the valve seal guides. Never had anything checked out. Last month, my gas consumption cruised on up within a tank going from 600kms a tank to 400. Shortly after I began to be able to smell oil burning.. Mostly out of the turbo area. Now just last week, this smell changed to nearly that of burning rubber. So my question is this, could this be an issue with the turbo (as I checked the turbo for issues i found oil in the compression/up-pipe side) or is this an engine issue?
 

·
Premium Member
Joined
·
6,716 Posts
1L between changes is a normal amount of oil consumption for these cars. According to Subaru, up to 1 quart every 1000 miles is withing spec.


From what you're describing, it sounds like you might have a leak at the oil return line under the turbo. That's a fairly common area to develop leaks, and shouldn't be too difficult to fix. First things first, I would try cleaning every thing off really well (Simple Green, a stiff bristle brush, and spray it off with water works well for me), then take it for a short drive. After everything cools back down see if you can get a look at it and determine exactly where the oil is leaking from.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I am in the proccess of getting it into the dealership for them to take a look at it. The smell of the burning oil and the gas mileage is enough to get help. I have been told it could be valve cover gasket, turbo seals, pcv, and to check the spark plugs for oil.

Honestly I have tried to find the spark plugs briefly on my wrx 04 2.0L and I did not make it very far.
 
1 - 5 of 5 Posts
Top