ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
I have an Sti trans into my 04 wrx, just recently done a month ago...
This has been happening for two week now and its getting really annoying. On some occasions when shifting in low rpms (only when going to 5th gear) it will pop out of gear a few seconds later. To describe it better; I'm in 4th gear accelerating, around 2.5k rpm i upshift to 5th and as soon as i am letting go of the clutch and getting back on throttle, within that second it pops back out into neutral leaving me revving.

All in all, what may be causing this? as I'm REALLY worried for the fact that I've spent so much money on the swap not too long ago, and now it looks like I would have to spend more. Don't get me wrong I love my subbie, but wow, now in the back of my head I'm considering moving on and getting an evo. I really dont' want to though.


* Things I've noticed

-- does not always occur.
-- Only happens in low rpms. When shifting at 4k or greater, it does not pop out.



Thanks so much in advance for the help.
 

·
Registered
Joined
·
6,751 Posts
So you have a full drivetrain swap not just the tranny correct? Does anything about 5th gear feel funny when you shift into/out of it? It sounds to me like the shifter linkage may have an issue somewhere, especially the part that goes into the tranny.
 

·
Captain James of the SS Impreza has gone down with
Joined
·
8,921 Posts
If you only swapped the trans, did you make sure the FD gear ratio was the same? Is this one of the RA STI trans or is it the USDM 6spd?
 

·
Registered
Joined
·
118 Posts
Discussion Starter #4
Sorry I have not been on in a while, been busy with school and stuff..... But yes, the FD on the trans is 3.90 so I got a 3.90 LSD differential to match up. How exactly would I go and check if the shift linkage is good?

Hopefully your right, not trying to spend another 3-4k on a trans, seriously.
 
1 - 4 of 4 Posts
Top