Subaru WRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Good morning!
I have recently installed an IAG Street Series Air Oil Separator onto my 2004 WRX. Shortly after, I began to hear a distinct "supercharger-like" whining noise coming from the engine. The noise only happens when the car is going into boost, around 2500-3000 rpm, and also only when it's in gear. The noise started off quiet but recently I have noticed that it started to become louder. I was wondering if the separator is causing the problem or if it's related to anything I may have done during the install. I also have checked any visible vacuum lines, intercooler pipes, and turbo inlet for leaks. Some help or advice on what is causing this issue would be much appreciated!

Also some additional notes:
-This car has a JDM EJ207 swap from S204 with less than 45,000km (~28,000mi)
-Only other mods done to the car are a cold air intake and turbo back exhaust, both of which were installed a very long time ago.
 

·
Super Moderator
Joined
·
11,143 Posts
Did you check the intercooler to throttle body pipe? Mine leaked there and made a very similar sound.

It could also be the sound of the vortex in the aos. Some of them make a whine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the quick response!

I did check all the intercooler pipes but I'll check that one again sometime later today.
I was kind of thinking that the AOS might be making the noise because of its design but I didn't know it could be so distinct and loud from inside the cabin.
 
1 - 3 of 3 Posts
Top