ClubWRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,915 Posts
Discussion Starter #1
My friend was driving behind me @ around 30 mph and I hit the gas. When the turbo kicked in he said he noticed white/grayish smoke with a hint of blue (he wasnt really sure about the blue) coming out of the exhaust. Here are my mods:

vf34
walbro pump
sti injectors
3" turboback with high flow cat
perrin pulley
accessport vf34 map
samco ic hoses

The vf34 has about 4,000 miles on it.
I sure hope its not the turbo seals or anything like that. I do have a tear in my stock turbo inlet hose and a perrin inlet is on the way. Theres no smoke at idle or when I rev it, just when the turbo kicks in. What do you think?
 

·
Registered
Joined
·
1,915 Posts
Discussion Starter #3
Yeah Ive read numerous posts where they say its normal due to a catless or near catless setup, but then a few posts stopped my heart:

"Oh my gawwwd I blew the turbo seals/ring landings/piston/bearings !!! and on of my simptoms is gray/white smoke!!"

I also heard white/gray smoke coudl also mean running lean....


I will check the dp for any oil when i put in my new exhaust and see if the new inlet helps....
 

·
Registered
Joined
·
1,915 Posts
Discussion Starter #4
Hmm now I notice my coolant goes down about an inch every week. I am not sure if this si just a continuation of the "burping" of ym system since I changed the coolant a few months ago or not. How bad is it if the turbo burns coolant under high boost? Will it be noticable and come with a loss in performance?
 

·
Registered
Joined
·
1,915 Posts
Discussion Starter #6
I was already aware of those but thanks anyways. Can someone answer my other questions?
 
1 - 6 of 6 Posts
Top