Subaru WRX Forum banner
1 - 4 of 4 Posts

·
Registered User
Joined
·
2,210 Posts
Discussion Starter · #1 ·
You need:

- Molex connector of the size used by the UTec.
- Crimp-type pin for molex connector (radioshack)
- 5ft of electrical wire (18 or 20ga is fine).
- 2 male spade connectors (small)
- 2 female spade connectors (small).
- Ring terminal.

1. Strip the end of the wire and crimp on the molex pin.
2. Insert molex pin into molex connector in pin position 5 (see UTec pinout schematic for details).
3. Remove the connector/harness from the clutch switch. This is located near the clutch pedal pivot, and is the lower of the two switches that appear to be located there. It's stubborn as all hell to remove.
4. Route the wire from the molex connector to the clutch switch. Crimp female spade connector to end of wire. Plug female spade into one of the clutch switch terminals, NOT the harness terminal.
5. Using a short piece of electrical wire, put a ring terminal on one end of the wire and the remaining female spade connector on the other end. Insert the remaining spade connector into the clutch switch. Ground the other end (ring terminal) at a nearby chassis point.
6. Take a 2" piece of electrical wire. Strip both ends, and fit male spade connectors to both ends. Insert both ends into the connector for the harness that was formerly plugged into the clutch switch (it has two female terminals). This is necessary to fool your cruise control so it doesn't 'think' that the clutch is always depressed.
7. Enable launch control in the UTec interface.


If you can't follow simple instructions, I bear no responsibility for you screwing things up. DO NOT splice the wire from the molex connector into the cruise harness. The cruise harness MUST be disconnected from the switch as I stated.

-Pace
 

·
Registered
Joined
·
253 Posts
how did you get the female connectors on the clutch switch. seems like they were recessed too far into the plug. i have the turboxs map switch, and ended up just cutting off the factory plug, wiring that into the launch control harness, and then soldering the wires i cut together. i left plenty of wire on the plug to attach in back to the factory cruise defet wiring if/when i ever need too.

i was just wondering if it was possible to get the female connectors onto the plug.


cnstman
 

·
Registered User
Joined
·
2,210 Posts
Discussion Starter · #3 ·
cnstman said:
how did you get the female connectors on the clutch switch. seems like they were recessed too far into the plug. i have the turboxs map switch, and ended up just cutting off the factory plug, wiring that into the launch control harness, and then soldering the wires i cut together. i left plenty of wire on the plug to attach in back to the factory cruise defet wiring if/when i ever need too.

i was just wondering if it was possible to get the female connectors onto the plug.


cnstman
I had no problem getting them in there. I used electrical tape to prevent them from coming disconnected.

For the cruise harness, I could not find male spades small enough, so I just trimmed down the ones I had with some snips. It works, and it didn't cost $80!! :eek:

-Pace
 

·
Registered
Joined
·
253 Posts
i got my switch for 50 when they first came out, i would have to really think about spending 80 for it now. but in true txs fashion the did upgrade me for free to the launch controll switch.

i guess i did not try hard enough to get their harness to plug in, i found it easier to just cut and splice harnesses. either way it works i guess!

cnstman.
 
1 - 4 of 4 Posts
Top