ClubWRX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey everyone. I just got my new (to me) 2015 wrx sti from a dealer out of province a week ago today. The car is in great condition expect it shown up after a 10 hour drive for me to purchase it with light white smoke coming from exhaust. Didnt think much of it. But two days later it through a p0123 in idle before work. Engine light went away after work and a short drive. Was omw home from work Thursday, parked and sat in idle for a bit and it happened again however this time the car went into limp home mode. Got the car home, checked the fluids and the oil seemed to turn darker and lower then it was before and coolant was lower. Started it after unplugging the battery for a bit and it ran fine for a bit. Let it sit in idle for a bit again, ran better then before and the problem happened again and this time a LOT of white smoke started coming out and I haven't started the car since. Have to wait till tuesday for the car to get picked up :/ any info would be appreciated as I'm pretty sure it's my headgasket and something in the ecu
 

·
Æternum
Joined
·
20,436 Posts
Time for a leakdown test. Is there yogurt in the oil?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Seen a tiny bit of yellow yogurt under the oil cap, otherwise nothing. Dropped the oil and it was black but smooth and not gritty. Seems like its chewing through coolant. Getting it picked up this week
 

·
Æternum
Joined
·
20,436 Posts
I bet someone dumped their project off on a dealership.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Kinda seems that way. Just put new fluids in and ran rough for a few mins then ran fine but still has a bit of white smoke. Oil cap had a bit of white smoke coming outta it after the engine got to temp and I topped up the oil. Is the secondary air pump important? Also the thing doesnt overheat but f*ck it doesnt like to cool down
 

·
Æternum
Joined
·
20,436 Posts
Define "important."

It's important for emissions but not essential to the operation of the vehicle if properly deleted.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Still need to pass a provincial safety haha so might be an issue. Looking like they might give me a new car but it wouldnt be an sti :( seems between an Evo and a Caddy ats
 

·
Æternum
Joined
·
20,436 Posts
For the record, my 2015 STI has regularly consumed a small amount of coolant since new. Never figured out why. Dealership did 2x leakdown tests early and it passed both with flying colors. Never did figure it out.
 

·
Æternum
Joined
·
20,436 Posts
Still need to pass a provincial safety haha so might be an issue. Looking like they might give me a new car but it wouldnt be an sti :( seems between an Evo and a Caddy ats
Well shit, neither can be new since they've both been discontinued.

The ATS is a great car to drive. Really great chassis.

I do love my Evos though...
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Went for a cruise and just before I got back it flipped the cel and limp home mode again. No white smoke on exhuast after I parked but she's still at operating temp 20 mins later. Done screwing with it till the shop picks it up. Also think my turbo is greasy asf and might have been a lil smoke coming from it
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
new to me haha I'm just in the market for an awd turbo'd and fell in love with sti's. Got this thing at a great price for the year (guess I found out why) the Evo is 2013 but has a 5 speed manual and some other work on it for 23,500 CAD. Caddy is 2015, was a leaser with low km and great maintenance records for 18000
 
1 - 14 of 14 Posts
Top