Subaru WRX Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
So a couple weeks ago omw to CO after a fuel up my turbo just stopped no smoke nothing i just recentley installed a hks bov it worked fine, but now my exhaust isnt as loud i used to be able to have my windows up and music up and hear my exhaust now they cant even be down and hear it it has absoultley no power going up hill at all or any at that. my check engine lights on took it to get read the reading were - System to lean bank - 1 (cylinder number 1 denotes bank 1)
1: Faulty Maf Sensor
2: Large Vacum Leak
3: Low Fuel Preassure
4: Plugged injector or cylinder misfire
i just bought and installed a new MAF that didnt help i bought new spark plugs today aswell installing them tommorow idk if that will do anything but im hoping.

if anyone can give me some advice id really appreciate it this is driving me crazy im not used to not being able to pass cars omw to work ha, i just really hope my turbo isnt out i cant hear any noises suelaing etc from it and no smoke ever came out plzz help
 

·
Registered
Joined
·
611 Posts
yuck.

please stop driving the car until you've figured this out. Something's seriously wrong with the car, and driving it risks more damage.

It sounds like you have an intake leak - and a serious one at that. The MAF is unhappy because air's getting in that shouldn't. You're not getting power because you're too lean and the turbo's probably just blowing air out into nowhere when it gets the chance. Your fuel line CEL's are still unexplained by this, but probably either false errors from the intake problem or you also have an unrelated fuel line problem (probably intake related - misfire from too high an EGT, low fuel pressure because the car's trying to pull too much fuel to counteract the air)

Anyway, what to do: Check your ENTIRE intake system - from the intake funnel (I'm REALLY hoping you have stock intake. If not, put the stock intake back on) all the way to the manifold. Check the MAF housing, check the turbo inlet, check the turbo cold side, check the intercooler piping, the intercooler itself, and the mani for cracks, rips, tears, bad gaskets, wrong torque spec, etc. Take your BOV off and put the stock BPV back on (what you have is a noisemaker that will make you run rich between shifts - if you're okay with that, put it back on later), make sure everything there is put on correctly as well.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Alright Thanks ALOT im having it looked at by a garage Monday and ill write this down and tell them to check it all. and i have a aftermarket intake came with it so i dont have the stock one ughh..
 

·
Registered
Joined
·
611 Posts
Alright Thanks ALOT im having it looked at by a garage Monday and ill write this down and tell them to check it all. and i have a aftermarket intake came with it so i dont have the stock one ughh..
trade whatever intake you have for someone's stock system, or get a tune. That could be one of the major factors in this. There are plenty of idiots^H^H^H^H^H^H folks who would want that trade as much as you want the intake off your hands.

The garage will be able to figure all this out, but tell them just to save some time that you're 100% positive it's a pretty major intake leak.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
thx i really appreciate the help ive asked alott of people but noone knows anything about turbos and neither do i. and say i cant find a stock one how much u think a garage would charge me to tune it?
 

·
Registered
Joined
·
1,433 Posts
Yeah you can pick one up from the dealer, but id check the classifieds here and on nasioc.com in the local sections.... also I'm pretty sure you'll find a few on ebay as well for a lot less then the dealer... pick up a stock intake system too while your at it... what year is your wrx? There is an 02 part out I saw just barley posted... I'm very certain your bov is leaking causing your issue and the intake isn't helping matters... your turbo wasn't spooling cause your ecu is in limp mode protecting the engine from damage...
 

·
Premium Member
Joined
·
11,798 Posts
put your stock bpv and your stock intake back on.

I have a stock bpv for sale, but I don't have the elbow or the hose.
 

·
Premium Member
Joined
·
11,798 Posts
20 bucks + shipping... or if you're up in denver, 20 bucks without shipping.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
so i took it to the garage earlier and just called them he said the guys were still checking things but they are leaning towards the turbo but thing is never seen smoke come out and i dont hear anything wrong with it when im driving it only has 53,000 miles on it could it be because i dont have that bypass valve on it? when i first put a bov on it worked fine . now my exhaust isnt loud and i have no rush
 
1 - 16 of 16 Posts
Top