ClubWRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
Hey guys. First off, i'm new to this site and I haven't had the chance to introduce myself in the new members section. This is my first WRX, and i'm definitely a noob. If i've made any mistakes please bring them to my attention. Thanks!

I'm in a bit of a jam here.. I bought a 2004 WRX with 8x,xxx miles on it. The original owner spun a rod bearing so he bought a shortblock with around 40,000 miles on it. While he was swapping the engines he bought a bunch of engine mods and sold most of the original parts. Every single thing is disassembled except for I have the two shortblocks, and the intake system is still put together for the most part. The owner is being deployed overseas, so he had to sell the car before he was finished.

He bought a new header with up pipe, and a big 16g turbo. (Every exhaust piece is aftermarket. Header, up pipe, down pipe, and cat back with high flow cat) I was just fiddling around with the parts and decided to match the turbo to the up pipe. When I did that I found out the turbo doesn't fit. I went to match the turbo to the down pipe and that doesn't fit either... So i'm pretty sure this is the wrong turbo, but I did some research to be sure. The turbo is a TD05, 16g, and I cannot find the manufacturer. The owner doesn't remember where he bought any of the parts, and has no receipts. I looked a bit harder and discovered this turbo has an A/R of .70, all of the turbos I looked at with that A/R have the same square up pipe mount as the one I have. I searched the A/R for a WRX and found a few 16g's that use A/R.49, and the turbos with that A/R seemed to have the correct mounts, at least for the downpipe.

The up pipe mount is different from the OEM gasket. (OEM up pipe gasket picture http://www.jscspeed.com/images/products/cb617db0a3e9bae5.jpg) I have the original up pipe and the mount is the same as on the aftermarket one. All of the turbos i've seen for the WRX have the up pipe mount that matches the OEM gasket, and not my up pipe. Please use the picture I uploaded for reference.

So it looks like I have the wrong turbo..
Are there any adapters or anything i'm supposed to use? Or do I have to buy a new turbo?
If I have to buy a new turbo, should I stick with the 16g? 730cc injectors and Wally 255. I have an extremely low budget though =/

So, any suggestions?
Thanks!!
~ Randy IMG_3519.jpg IMG_3521.jpg IMG_3522.jpg IMG_3525.jpg IMG_3526.jpg
 

·
Premium Member
Joined
·
6,501 Posts
Sell that turbo and buy one that is specifically made for Subarus.
 

·
Premium Member
Joined
·
15,697 Posts
Yeah, looks like a DSM fitment.
 
1 - 6 of 6 Posts
Top