Subaru WRX Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
2002 WRX Impreza Wagon 2.0T 5-speed

So I replace the clutch kit and had fly wheel turned. It's been about 5months now and it's running. But almost Everytime on take off it shakes.

Control arm bushing and ball joints replaced as well.

Anyone have any insight on this or have had it and fixed it already, greatly appreciated thanks...
 

· Registered
Joined
·
500 Posts
Wish I could help, but I can commiserate. I have a 2016 WRX, recently had the throw-out bearing, clutch, etc. replaced under warranty. On take off, regardless of RPM, the car will shudder/shake on take-off in 1st and sometimes in 2nd. A smooth take is almost never possible, even on the slightest of hills. The clutch isn't slipping, as once it's in gear the rpms reflect the acceleration (or lack of).

I plan to take it to Subaru to look at things. It sucks. I took it in for a whistling noise when cold/wet and now have driving issues. <sigh>
 

· Premium Member
Joined
·
4,858 Posts
Based off what I've heard, resurfacing the flywheel tends to cause problems and it's recommended to replace it rather than. Sounds like the clutch is chattering which could be caused by improper break-in procedures, or simply running it too hard now and you need to be easier on it for a while to remove any build-up.
Or, could mounts.
Those would be my guesses
 

· Registered
Joined
·
22 Posts
I recently had the clutch in my 2004 WRX Wagon replaced and the fly wheel machined. I had shuddering that was most noticeable in reverse. The tech advised to give it time and it's lessened but not completely gone. I'd say replacing the flywheel might remedy the problem, as mentioned above already.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top