Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hey , so thought someone here might have some good info or at least point me in the right direction to figuring out whats happened or wrong...
I have a 09 WRX & had to change the driver side , rear wheel bearing. So once I changed it & buttoned everything back up , the test drive had the Traction control , Hill Assist & ABS dash lights come on......cruise dont work now either....Im guessing that related to the dash lights being on.....when I first start the car , no dash lights are on but after about 10' of driving they come on & stay on.....

So just wondering if someone might have some ideas or suggestions what to do or where to look ? these lights were never on before i changed the wheel bearing.

Thanks in Advance
 

·
Registered
Joined
·
5 Posts
Hey , so thought someone here might have some good info or at least point me in the right direction to figuring out whats happened or wrong...
I have a 09 WRX & had to change the driver side , rear wheel bearing. So once I changed it & buttoned everything back up , the test drive had the Traction control , Hill Assist & ABS dash lights come on......cruise dont work now either....Im guessing that related to the dash lights being on.....when I first start the car , no dash lights are on but after about 10' of driving they come on & stay on.....

So just wondering if someone might have some ideas or suggestions what to do or where to look ? these lights were never on before i changed the wheel bearing.

Thanks in Advance

Visit Auatoguysland to review more reasons why the traction control and ABS light to stay on.
It may be relate to the wheel bearing hub. you can try removing the sensor from the wheel bearing hub and cleaning off the rust. If that doesn't work, replace the new one to eliminate the ABS light on.
 
1 - 3 of 3 Posts
Top