Subaru WRX Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Just had Helix uppipe, Perin downpipe, and SPT midpipe and Muffler installed. Now catless. More zip, nice sounds but I believe I am hearing some pinging above 45K under hard acceleration, but not sure if its pinging or not the exhaust is new and kinda loud.What I should do. Do I need a reflash? :confused:
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
I'm new at the Mods, and have heard of resetting. Is this difficult. How do I do so. Thanks.

Peter
 

·
Registered
Joined
·
42 Posts
Disconnect the negative terminal of your battery, hold down the break pedal for ~15seconds, reconnect the battery... done. Since you are pinging I don't think you should worry about the Vishnu fast learn method... just let the ECU relearn normally by driving.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
pinging after reset ecu- or not?

thanks for info. I reset the ecu, put 80 miles on , than another 40 miles on. Still THINK I am hearing pinging under hard acceleration over 45K. a) Am I not giving ecu enought time to learn? b) is what I think is pinging not pinging (clips of pinging? ) c) being that I am catless am I just hearing more engine noise, which might sound like pinging. Is there any way to tell if I am getting detonation besides what I hear in cabin... thanks
 

·
Registered
Joined
·
3,478 Posts
When you say 45k do you mean 4500 rpm? If so, you might just be hearing noises that are muffled by the stock cat(s). Im guessing you aren't running any engine management and installing those parts cant really cause you to ping unless you put crappy gas in or something.
 

·
Banned
Joined
·
601 Posts
Your exhaust might be hitting the frame of your car too. If this is the prob, loosening the bolt in the middle of the downpipe, pushing the exhaust over to the passenger side of the car and tightenning the bolt might help.

peace
 

·
Registered
Joined
·
1,535 Posts
After I did my whole exhaust I thought I heard pinging too, but after awhile I realized it was just the normal boxer engine noises being "amplified" by the absence of the heatshields.
 
1 - 8 of 8 Posts
Top