ClubWRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey guys, does anyone know how to torque the very top strut bolt? I can't get the shaft to stop spinning??? I have HKS hiper Ds
 

·
Premium Member
Joined
·
15,697 Posts
Install them in the car, then try to torque it.
 

·
Captain James of the SS Impreza has gone down with
Joined
·
8,921 Posts
Or use a strap wrench.
 

·
Registered
Joined
·
184 Posts
I just installed Epic springs a couple days ago ... I also had this issue. Are you trying to torque them to spec .. or just tighten them? What i did was take my 14mm socket and used a vice grip to hold onto it. Put it on the top hat bolt and then I put the allen wrench through the middle of the socket and tighten it that way. It worked well!
 

·
Premium Member
Joined
·
15,697 Posts
I just installed Epic springs a couple days ago ... I also had this issue. Are you trying to torque them to spec .. or just tighten them? What i did was take my 14mm socket and used a vice grip to hold onto it. Put it on the top hat bolt and then I put the allen wrench through the middle of the socket and tighten it that way. It worked well!
I ended up doing something similar last time. Usually just putting them in the car and putting it back on the ground will do it though. Once you get them fairly tight you should be able to use a torque wrench and have the shaft stay put.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
So iv managed to torque the top bolts to the correct specs. Iv replaced the steering rack bushes also but I'm still getting a slight 'knocking' noise. Iv re-used the The standard top hats, would the next bet be to replace them???
Also, with the struts out of the car the front top hats should be able to spin freely should the rears be able to do the same??
 

·
Premium Member
Joined
·
15,697 Posts
The rears don't need to spin.

I get a knocking - it is due to my wing on my wagon flexing that panel.
 
1 - 8 of 8 Posts
Top