ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
Well, I got most of the TBE install done except for two things.

One: The heatshield. For the love of god I cannot get it back on. Seeing as how I was already pretty tired when I was taking that off, I don't think I remember to reinstall it correctly.

Two: The Rear 02 Sensor. For some reason, the plug will not reach far enough to get into the hole infront of the cat. I started the car up and gave it a bit of a test drive (without the 02 sensor/heatshield, probably a stupid thing to do) and it automatically threw a CEL. There also seems to be a rubber tube resting against the downpipe that is burning and causing a funny smell.

So! My plan of action is...

Someone to come help me. :D I'm usually free anytime after 1am (yes, one in the morning) and probably early Saturday morning. After that I'll be out of town for about a week and if I can't get anyone out here in the next two days, I'll bump this.

I'll buy food or whatever for whoever comes. Thanks.
 

·
Registered
Joined
·
739 Posts
I cut off both plastic clips that hold the O2 sensor onto the body of the car. Afterwards, I just used a ziptie to hold the wire in place.

I didnt bother to put the turbo heatshield back on. It wont fit unless you cut parts of it. I ordered a Speedmonkee heatshield which should be coming in today or tomorrow.
 

·
Registered
Joined
·
1,948 Posts
Just as the other guys said,

1- order an aftermarket heat shield
2- that rubber hose push aside, there is a little lip you can set it on.
3-rehang the rear 02

And your set
 

·
Registered
Joined
·
474 Posts
I just trimmed my heatshield with some tinsnips and it fits perfectly now.

With the O2 sensor, there is a clip that is pretty much in the engine bay that is holding the wires in place. I didn't have enough slack to re-install the O2 sensor until I removed that clip, then I had enough wire to re-install it and zip tie it out of the way.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #7
Thank youuuuuuuuuuu everyone!

I couldn't find the other clip last night, but I wasn't looking either, so I'll crawl under it again sometime soon here.

I've also mangled the stock heatshield trying to get it to fit so I would bet the SpeedMonkee would fit best. By the way, I have a Vishnu DP.

Thanks again, and thanks Harvey. Like I said, I did give it a test drive and while it was louder (still need gaskets) than what I had originally wanted, I fell in love with it.
 
1 - 7 of 7 Posts
Top