Subaru WRX Forum banner
1 - 20 of 48 Posts

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #1 ·
Ahhhhhhhhhhhhhhh, im dying here. Been without my car for almost three months.

Nobody i talk to can help me get this stupid thing wired up. Ive called lachute and rallispec, and when i ask for a wiring diagram they send me sheets with all the pinouts. What the hell is that, its not a diagram so dont call it one.

I need to find out if anyone knows how to do the conversion, if they know anyone that does, and if theres anyone in south florida that knows how to do this or has the info on how to do it.

I just want to get this thing done, its really getting annoying how nobody has a clue how to do this or can tell me how to .

end rant
 

·
Banned
Joined
·
968 Posts
Bump for you John.

Post this on NASIOC. Someone will probably know there.
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #4 ·
Thanks, i advanced this to both i-club and nasioc. I thought about the manuals, but the problem is getting the manual for the jdm sti.

Ravensblade looks like it might have what i need, so ill check that out.

-John
 

·
Registered
Joined
·
72 Posts
I've got a 2.5 block in my car but I kept the wrx ecu so I didn't have to go through the issue you are going through. I'd help if I could.

Carlo
 

·
Registered
Joined
·
381 Posts
We sold a V8 setup to a local guy who dropped it in himself and ran it for a while of the WRX ECU albeit with no AVCS, he had to change the throttle cable mounting slightly. He has since then located and brought a ECU from Japan (you have to give them your engine number for a V8) and wired in the AVCS and is having no problems.

There should be very little wiring to worry about as long as it's the JDM spec engine.

Mike
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #8 · (Edited)
Picture 1
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #9 · (Edited)
Picture 2
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #10 · (Edited)
Pic 3

This is on the STi engine
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #11 · (Edited)
pic 4

This is on the wrx engine, but its not on the STI, is this the TGV's and can we just eliminate the wires for it?
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #12 · (Edited)
pic 5

This is part of the STI engine, and the wrx engine harness has no plugs that go for that. Is this part of the AVCS?
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #13 · (Edited)
pic 6

This is part of the wrx engine harness that we transferred to the STI engine.
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #14 ·
These are all wires we have questions about.
 

·
Registered
Joined
·
1,959 Posts
Isn't there a guy with a V8 STi from New Zealand that posts on here all the time? Maybe he can help you. From my understanding, it is exactly the same as the the JDM model.
 

·
Registered
Joined
·
1,433 Posts
The pics you have questions about i can answer... we have had several version 8 sti's come thru here.

The pictures are for the TGVs you can leave that unhooked, but it will throw a CEL.

The other picture is for the AVCS that sti cylinder heads have. You can wire that up if you like.

-Mike

Lemme know anything else, I can be more specific.
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #18 ·
Chunks said:
I would pm that cabby996 guy, he has done this....
I talked to him and he used all the wiring from a spec c, so ya, thanks though.

-John
 

·
Registered
Joined
·
1,318 Posts
Discussion Starter · #19 ·
MJU1983 said:
The pics you have questions about i can answer... we have had several version 8 sti's come thru here.

The pictures are for the TGVs you can leave that unhooked, but it will throw a CEL.

The other picture is for the AVCS that sti cylinder heads have. You can wire that up if you like.

-Mike

Lemme know anything else, I can be more specific.
Ok so we were right about the tgv's, but why would they throw a cell if the STI ecu is not meant to use them:confused: and is there a way to get it to not throw a cell?

Also which picture was for the avcs? I have the pinouts etc for the AVCS i just need to know which pictures are the avcs.

If you could post it like this
pic1=
pic2=
etc etc etc that would be great. I also put pic numbers above the pics so i know which one etc. Thanks for the help.

-John
 

·
Registered
Joined
·
1,433 Posts
DEADPOOL said:
Ok so we were right about the tgv's, but why would they throw a cell if the STI ecu is not meant to use them:confused: and is there a way to get it to not throw a cell?

Also which picture was for the avcs? I have the pinouts etc for the AVCS i just need to know which pictures are the avcs.

If you could post it like this
pic1=
pic2=
etc etc etc that would be great. I also put pic numbers above the pics so i know which one etc. Thanks for the help.

-John
Ok, in a WRX with a ver 8 manifold... It threw a CEL. If the STi ECU doesnt have them obviously, it shouldnt throw one.

And PIC 5 is the AVCS.

-Mike
 
1 - 20 of 48 Posts
Top