ClubWRX Forum banner

1 - 13 of 13 Posts

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #1
So I started my TGV deletes tonight. I would have put this in my progress thread but the forum wouldn't let me into my thread, oh well. Disassembly went pretty smooth, had a couple of snags due to not having the right tools. Once I got a drill for the pinned screws in the butterfly valves, everything went well. I am going to grind out the partition tomorrow.

316836_10150993598385297_716260296_22076952_1148420441_n.jpg 384613_10150993176825297_716260296_22075302_1835071882_n.jpg 390778_10150993178270297_716260296_22075307_1175506099_n.jpg
 

·
Master Baiter
Joined
·
22,115 Posts
Are you welding, using screws, or using block-off plates (e.g., KSTech)?
 

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #3
I have heard quick steel compound works. I might go with caps though.

I was holding off originally until I got some new gaskets from KSTech, and I disassembled everything and my old gaskets look great. Whatever, Ill just replace them anyway.
 

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #5
So is there anything I should do before I fire this thing up? Besides deleting my TGV CEL's? I only ask because a local guy on his 05 STi just did deletes and said that he knocked pretty bad until he reset something. It didn't make sense to me I kind of disregarded.
 

·
Registered
Joined
·
2,663 Posts
Pretty sure you need a tune to run TGV deletes?? Could be wrong though
 

·
Premium Member
Joined
·
17,655 Posts

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #8
Well I was told to not adjust my cold start enrichment until it specifically needs it. No reason to see knock though right?
 

·
Premium Member
Joined
·
6,501 Posts
When you reflash the ECU with the TGV codes disabled it should clear any learning from RAM. I would just double check with Learning View after flashing that indeed any fuel or knock learning has been zeroed out. If not just reset the ECU.
 

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #10
Yeah every time I flash a new map, it zero's out my learning correction and IAM on Learning View.
 

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #11
Alright so got her all started up and no leaks. :D Surprisingly my idle didn't really wander at all. I revised my map to disable all TGV related CEL's but did not touch my warm-up enrichment and it did just fine. Got it warmed up and took it for a spin and she really had some more pep in her step. I think this mod really complemented the 20G.
 

·
Registered
Joined
·
2,663 Posts
hmmm this is interesting. I was really under the impression that it required a tune but I stand corrected
 

·
Boost > NA
Joined
·
809 Posts
Discussion Starter #13
Yeah based off of Unibomber's Manifesto you do not need to tune, the only 'tune' like work you would have to do would be taking care of the TGV CEL's thus averting limp mode and possibly warm-up enrichment if needed. So far every time I have started my car when it's cold, I almost can't even tell I deleted my TGV's.
 
1 - 13 of 13 Posts
Top