ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Stage 2 w/ Cobb AP.....So I am only getting up to about 14.5 psi or so. I used to get up to 16. 14.5 is a little low (target = 15.2 +/-0.7psi). My question is, shouldn't the ECU make adjustments to keep the boost in the proper range? Or would it require the addition of a boost controller or manual manip of the wastegate arm to bump it back up to spec? I do not have any apparent boost leaks from the intake manif. thx
 

·
Master Baiter
Joined
·
12,649 Posts
shmee40 said:
Stage 2 w/ Cobb AP.....So I am only getting up to about 14.5 psi or so. I used to get up to 16. 14.5 is a little low (target = 15.2 +/-0.7psi). My question is, shouldn't the ECU make adjustments to keep the boost in the proper range? Or would it require the addition of a boost controller or manual manip of the wastegate arm to bump it back up to spec? I do not have any apparent boost leaks from the intake manif. thx
You're within target range (15.2 - .7 = 14.5)

That's a generic map for you.
 

·
Registered
Joined
·
1,229 Posts
How long has it been? When I flashed stage 1 I was hitting 12.9 the first few days, then ~14 after that, both within +/- 0.7 of target.

Not ultra familiar with the ECU's on these cars, and especially EM, but it can take a couple of tanks on other vehicles before it's done learning the hard stuff.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
yeah i know it's within range but my concern is that is was high (~16) and now it has dropped. I have been stage 2 for over a year
 

·
Premium Member
Joined
·
12,314 Posts
Check for a boost leak & all the lines for the BCS.
 

·
Premium Member
Joined
·
12,314 Posts
Sorry, you said the manifold but you need to check the intercooler hoses etc. You may need to make one of the testers with a gauge so you can apply pressure and listen for it leaking.

Are you logging the car? They used to pull boost when the IAM dropped to 4 (out of 16). Is your IAM maxed out?

Are you at a new higher elevation?

The next option would be your turbo failing, but that sounds odd for such a new car.

I would look at resolving this without adjusting the wastegate or changing the BCS since the car used to hit high boost.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Sorry, you said the manifold but you need to check the intercooler hoses etc. You may need to make one of the testers with a gauge so you can apply pressure and listen for it leaking.

Are you logging the car? They used to pull boost when the IAM dropped to 4 (out of 16). Is your IAM maxed out?

Are you at a new higher elevation?

The next option would be your turbo failing, but that sounds odd for such a new car.

I would look at resolving this without adjusting the wastegate or changing the BCS since the car used to hit high boost.
the cobb live data has readouts for ignition timing and i think advance. i can check these
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
IAM at WOT in 4th n 5th gear = 12.5°

maybe would it help to reflash the ecu? Couldn't hurt right? checked the IC hoses and didnt see any apparent leaks but it wouldnt hurt to snug everything up and maybe look at new hoses. do these hoses HAVE to be rubber?
 

·
Premium Member
Joined
·
12,314 Posts
the cobb live data has readouts for ignition timing and i think advance. i can check these
Cobb calls it (IAM) "DAM" and you can read it - I think for your year it should be maxed out at 1 (= 16 on mine).
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
so the "DAM" is running between 1.0 and 4.0 depending on throttle. Can someone explain ignition advance multiplier? i have abs no idea what it means
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
False. DAM is at 1.0. For the 2.5L, DAM is anywhere between 0.0 and 1.0. So the timing is good. Must be a mechanicAl issue. Anyone recommend some good IC hoses?
 
1 - 12 of 12 Posts
Top