ClubWRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I noticed that when my car is turned on for the first time in the day and sometimes later in the day after the car heated up (at idle not while driving at least noticably) there is a squeeking noise that comes from my engine bay. I no its nothing serious its coming from the pulleys or the belts. Is there any way to get rid of this noise possibly lubricating them??? If its the pulleys can I just spray some WD40 on the screws??? Any suggestions or people that experienced these noises recommend anything. I also hear the same noise coming from my 2000 Camaro SS.
The subaru is decently heavily modded (DR 500, SR40 20 psi and the works to back it up) and the SS is decently modded (bolt ons)

Thanks
Imran
 

·
Registered
Joined
·
2,539 Posts
If the prob is squeeking belts....IF that is.

They sell a non slip spray at Autozone,Wal-Mart,etc that you spray on and helps stop it.

.02
Shotgun
 

·
Registered
Joined
·
1,036 Posts
How about new belts or maybe a tension adjustment? Anything you spray on there is going to splatter everywhere in the engine compartment.
 

·
Registered
Joined
·
2,539 Posts
chevyeater said:
How about new belts or maybe a tension adjustment? Anything you spray on there is going to splatter everywhere in the engine compartment.
Sht, I forgot about that......

You are right, It isnt real bad unless you spray it heavy though.

Thanks for the update


Shotgun:eek:
 
1 - 5 of 5 Posts
Top