ClubWRX Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
so im pretty sure i spun a bearing in my 04 wrx, makes a loud tapping clicking noise that gets louder as the rpm raises, now my question is should i take it to a mechanic and say please rebuild my engine,or should i buy a used engine and swap it in?although i found no websites that have usdm ej20 engines while searching via google.
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
so im pretty sure i spun a bearing in my 04 wrx, makes a loud tapping clicking noise that gets louder as the rpm raises, now my question is should i take it to a mechanic and say please rebuild my engine,or should i buy a used engine and swap it in?
Why not take it to your mechanic and ask whether it's a timing belt tensioner or something else that is not a $3K problem? If you're sure you spun a bearing, OK, but nothing you've said so far indicates this.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #4
ok ill take it him, the reason i believe its a spun bearing is the sound my engine is making the loud tapping clicking noise. its in the rear of the engine is where it sounds loudest on the drivers side,i believe that is cylinder 3, i checked to make sure coils were good and tight made sure spark plugs werent loose, checked for loose bolts
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
Piston slap is not abnormal. Bearings and such of course are. If it's coming from the rear I am less optimistic than in my original question, but my experience is also very limited. Still, with that very limited experience, the only other issues that come to mind from that area are a mechanical rattle from physical contact among components around the motor (check all brackets etc.) or the gearbox, and the very rare, ultra elusive cracked flywheel. Other than that... engine internals. Hopefully it's not though. For now, patience, see what the issue is first, hold on to money as much as possible until you're sure.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #7 (Edited)
did a compression all were 140 except cylinder 2 was 120, took out the spark plug on cyl 2 and it had a yellow powdery substance on it,then while the engine was running
i pulled the dipstick out and there was some smoke coming out of the dispstick tube
,also noticed where the breather hoses attach to the intake there was an abnormally
large amount of oil does this means motors dieing?i would also like to note that it seems like i have less power car doesnt feel like it wants to accelerate in upper rpms(5000 to 6000 area), it will go there but very slwoy
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
Yellow powder could indicate a plug of incorrect temperature range, a combustion problem (if the powder is sulphur for example, or if the fueling is incorrect), or... nothing.

Did the other three plugs look normal?

I think cyl 2 is below the absolute service limit for the motor, and the Δ between that and the other 3 cyls is definitely above the service limit (they should be within 7 psi of one another) but I don't know what to make of the fact that you are hearing a noise on one end of the motor and pulling out a bad plug from the other end.

The oil does not necessarily mean the motor is going to die.

Can we start over?

What engine, what modifications, for how long, and when did the problem start? All that info could help someone narrow down the source.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #9
i thought cyl 2 was driver side? i thought it went 13
42
we can start over,
04 wrx 76000miles ej205 for that year i believe
modifications are none although when i bought it had an intake on it
i have since then put the stock intake on it
it also had sti injectors wich i returned to stock
the problem started yesterday i was driving,then all of sudden the car just shut off still had power but died
i started the car back up and then ever since then ive been hearing this noise
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
OK I seem to remember your previous posts too. It is extremely unlikely the car was stock. Nobody installs injectors just for their own sake. Since you have also had misfire problems in the past, I think the safest thing to do is to take the car to the shop, and I state this knowing it makes me sound utterly useless because I think it's what's best at this stage. Tell them the car was almost certainly modified in the past and list all the problems. I hope someone else can help more.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #11
your not useless man just that fact you are replying shows that you care and i couldnt ask for more:) should i go to subaru specifically or someone else?
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
your not useless man just that fact you are replying shows that you care and i couldnt ask for more:) should i go to subaru specifically or someone else?
Well a dealer may be of limited use if our suspicions of previous modifications are correct. It'd be great if there were an independent specialist in your area, that's where I'd start.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #13
ok hmm.well theres one guy whos called the subaru guru, but he wasnt the one that found the injectors i did and i guess that kinda made me lose faith in him because i went there several times and he didnt notice it, so idk if thats just me being upset or if thats a viable reason to no trust him, but i guess thats my only choice, he will prob just say its my fault or something stupid
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,230 Posts
OK here's an idea: with your location in mind, look on this and all other Subaru web sites for local installers or tuner shops or shops that specialize in these cars, including modifying them. Each site will usually have a regional subforum. Try here, try Nasioc, try IWSTI, try them all. See whom people are using.
 
1 - 15 of 15 Posts
Top