Subaru WRX Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So im not gonna lie im new to working on a turbo car. Usually was a truck/beater car type guy. But anyways my car is a 2011 wrx. All stock when i bought it. Just has a nameless muffler delete turboxs 50/50 bov and a mishimoto intake. Car was running fine with 0 problems. One day i was doing a 3rd gear pull and at about 4000 4500 rpms is started to stutter and hesitate. My first thought was boost leak. Made myself a tester and bov was leaking. Replaced with stock one and installed a boost gauge. Still had a leak so next step was IC- TB hose. Replaced that. While that happened bolt snapped in the turbo. Got that out got everything together and still not running right. Idles and drives fine just not proper boost. Vac is -12 according to my gauge but i cannot find a leak anywhere. Can someone point me in the right direction.
 

·
Village Idiot
Joined
·
2,450 Posts
Are you still losing pressure via the leak tester that you built? Spray down all the hoses and joints with soapy water while using the tester on the charge side of the intake track. Finally, check the metal tabs holding the core of the intercooler to the plastic sides of the intercooler. Those are known to pop loose causing the intercooler to split apart between the metal and plastic.

Also, that Mishimoto intake should technically be tuned for.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The soapy water method is what i have been doing which is how i discovered the bov was leaking. Just went out and checked the intercooler again and no visable leaks there or any hoses with water. Maybe its something leaking that i csnt get to? Im not to sure anymore.
 

·
Village Idiot
Joined
·
2,450 Posts
There isn't much that can leak that you can't get to. Any work done recently to the intake manifold? Check for a tear in the intake boot at the turbo.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
No work done that i know of. Im not even to sure if its a leak anymore. My gauge reads -12 at idle though. Could my intake cause different readings?
 

·
Village Idiot
Joined
·
2,450 Posts
Maybe. What gauge are you using to monitor boost? Do you have a way to monitor A/F Corrections?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I just installed a prosport digital guage T'd into the vac line going to tge bypass valve. But no, no way of reading afr. The car runs good up to 9psi according to the guage but once im at 9 or at about 4500rpms it stutters and levels off.
 

·
Super Moderator
Joined
·
11,452 Posts
My 2011 had a wicked leak at the tgv on both sides. I completely missed it when I was doing my TB IC hose, that I also snapped off a bolt in the turbo doing.

I would also check around the turbo inlet. Mine was shot and had to be replaced recently.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Premium Member
Joined
·
3,075 Posts
Second what XJ said
The throttle body hose, and the turbo inlet are prone to failing. Both collapsed on my 09. Never had an issue with the TGV though, but also worth checking

Also, definitely be careful with those turbo bolts that connect to the intercooler. You don't want to snap the heads off
 
1 - 9 of 9 Posts
Top