ClubWRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter #1
I'm a newbie who just picked up my 05 WRX last night. I am trying to keep it under 4,000RPM which is nearly impossible. After reading posts for months about turbo lag, I was expecting to notice something. I haven't yet. Push the pedal and it goes so very fast. Does it only happen when dragging at high speed or what? Could Subaru have fixed the problem for the '05?
 

·
Registered
Joined
·
1,302 Posts
Just Be said:
I'm a newbie who just picked up my 05 WRX last night. I am trying to keep it under 4,000RPM which is nearly impossible. After reading posts for months about turbo lag, I was expecting to notice something. I haven't yet. Push the pedal and it goes so very fast. Does it only happen when dragging at high speed or what? Could Subaru have fixed the problem for the '05?
nope.

turbo lag is the slow pickup of some turbos. The turbos on rexes are small and spools quickly then fades off. If you pull out hard.... after break in..... you'll notice the slow pickup from 2000 rpms until around probably 3500 or so. Then it'll push you in seat slowly after that. After 5000 or so it'll gradually fade away. But its the beginning of the acceleration where the lag takes place. Assuming that you know this already... try driving the STI. Turbo lag is there but due to the bigger, torquier engine and better turbo, the lag feels nonexistant. The easiest way to understand what and where it is, is to drive an STI and your rex back to back. Totally different power deliveries but you'll get an idea as to what turbo lag feels like. If you have any more questions... pm every single mod twice about this question. They'll be able to help:D
 
1 - 3 of 3 Posts
Top