ClubWRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Well friday i went to the drag strip for the second time with my 02 cobb stage 2 wrx, sti up, TBE, injen cai. First time i went i was stage1 and my best was a [email protected] with a bog for a launch. Much to my surprise my first run on my second track visit now @ stage 2 was a [email protected] with a bad launch again. I am using the gas blip/slip launch method @3-4k which i can get to work on the street but havent had success at thetrack yet. Talking with another subie driver at the track he suggested i blip my throttle between 4/4.5k and slip for a launch.

Here comes the freaky part.

Upping the rpms to between 4/4.5k i do a controlled slip launch start going and before you know it my rpms are screaming at 6.5k with my clutch pedal all the way out. I was "moving" but not like i should have something was not right and scared the crap out of me because all this was happening at 6.5k. Anyway i eventually went into second after the "launch" and took it easy down the track. Thinking i had really screwed somthing up i stopped the car and did some inspecting no visable signs of problems but smelled like clutch for about 1/2 hour.

Was this just my clutch slipping? My car has 70k and this was the first Use of the stage 2 power

I started the motor again to check it out and everything seemed ok but after ideling for abou 30 sec i noticed white smoke coming out of my exhaust i reved it a little and enough came out for someone to yell "looks like you need new rings!" so i turned the car back off and let it cool a little started it again. This time there was only a little white smoke not near as much and only after it idelled for a bit.

Is this because of me not having cats? What was up with all the smoke that one time?

The car ran fine all the way home even launched it after some toll stops and it was strong with no bog or problems. The exhaust has only a little smoke every once in a while after an idel. Probably due to not having cats.

Where do i go from here? Everything seems fine should i expect to change the clutch soon? Would i be ok to go to the track again?

Thanks
 

·
UnBanned
Joined
·
17,655 Posts
Sounds like a multitude of problems.

White smoke = water vapor.... if it was coming out of the exhaust.

and it sounds like you have a slipped clutch too.

:(
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Didnt look like water vapor however it was dark so it was hard to tell if it was bluish or white
 

·
UnBanned
Joined
·
17,655 Posts
Didnt look like water vapor however it was dark so it was hard to tell if it was bluish or white
Bluish is Gas, White is Water, Black is OIL.

Blue in very small amounts is probably from your lack of a cat, but if it billowed enough for someone to yell at you... It's not just from a cat.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I do know as a general rule that bluish smoke is oil and black is gas
 

·
UnBanned
Joined
·
17,655 Posts
I do know as a general rule that bluish smoke is oil and black is gas
you are dead correct. I appologize. Got that backwards!
 

·
Registered
Joined
·
192 Posts
i can smell clutch from here..just kidding.. sounds like you just slipped it a bit much hence the smell for 1/2 hour..smoking requires more looking into but with no cats some is normal
 

·
Registered
Joined
·
878 Posts
Sounds like you will be changing out your clutch soon, I had that happen on mine a couple of times when I did a hard launch, even though it was holding up fine in regular driving. However when 70k hit the clutch started letting go and I had to get it changed, no big deal however becasue now I have a brand new stg1 clutch and that sucker holds on tight... now more slipping under hard launches, although I haven't done many from the fear that now my trany will blow up:) i am t 99k now.
 
1 - 8 of 8 Posts
Top