Subaru WRX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Ever since my last upgrades (BOV and uppipe) I've been running extremely rich. I've also noticed that acceleration is not as good, and my gas/mileage is about 14 mpg driving conservatively (much worse than before).

Symptoms:

1. My A/F gauge always reads on the rich end, not only at full throttle which is normal, but at lower, constant RPMs too.

2. The CEL always comes on when driving slow around town. The ECU was checked twice and read "Rich Fuel Mix" both times.

3. Excessive carbon build-up on tail pipe and bottom of bumper.

4. Performance dropped

5. Gas/Mileage is worse than ever - 14 mpg

I know that the BOV will contribute to this, but I'm almost always rich, not just when shifting gears.

I've searched this forum for help, but havn't had much luck. Can anyone help out. I've been dealing with this for the last several months.:confused:
 

·
Registered User
Joined
·
1,911 Posts
Sounds like you have a leak somewhere after the turbo. THat would certainly cause a very rich condition. Check the turbo outlet, IC inlet, BOV flange for any leaks. With those two mods you should run a tad leaner than before so obviously there is a problem.
 

·
Registered
Joined
·
292 Posts
i got a HKS bov and turboback and I my A/F ratio reads all the way to the left (LEAN) when I do not have the accelerator pressed. When I give her a little gas it'll go just a bit past center (STOICH). Hmm I just realized I've never looked at it when I floor it. It should go rich then. I'm gonna check it out tonight.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks God, I'll check for leaks tomorrow.

CAI?? I'm still using the stock ECU, unchanged.
 
1 - 6 of 6 Posts
Top