ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
Just like the title says. 04 WRX @ Stage 2. Seems like when im 3/4 off the clutch im good. but once i let off when im in reverse it seems to pop out of gear. Any suggestions.

Just purch'd this car last week. So its still pretty new to me. Other that than that I seem to Grind going in the first from a stop. But if i put the clutch all the way down to the floor, i dont have the issue with first grinding. (is this typical?)..thanks.
 

·
Registered
Joined
·
6,751 Posts
Sounds like the shifter may be misaligned so it's not able to get fully engaged in R. Or the fluid could be low. Or worst case, the gears may have been chewed up.

How far are you pushing the clutch down when it grinds in 1st? Obviously not far enough ;), but exactly how far? That could be due to low tranny fluid too.

Was the car stage 2 when you bought it, or stock, or what?
 

·
Registered
Joined
·
174 Posts
Discussion Starter #3
Ok, Id say i sunk the clutch in anywhere from 80-90% to the floor going into first, But when i sink it to the floor, I dont really notice the problem.
Yes car was stage 2 when i bought it. only 44K miles on it, i think it went Stage 2 around 20K. I'll certainly check the fluid. I really just hope that it is fluid. hopefully the other items arent expensive if thats what i need.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #4
Went by the dealer with my problem, they test drove it, and wanna pull the tranny, (told me to bring it in on Tuesday) they said that would check with SOA and see if the car has been blackballed in anyway, apparently no one there has heard of this issue before, Im afraid they will tell me its abuse when they drop the tranny, if not, then it will be taken care by the powertrain warranty still left on the car :crosses fingers:
 
1 - 4 of 4 Posts
Top