ClubWRX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
No it isn't the typical 04 STi clunk question.

02 Bugeye and have brand new BC coilovers all around, but have clunking emanating from the rear end. predominately passenger rear side. Only happens while going over sharp/abrupt bumps @ any speed. I'm leaning towards the old bushing in the lateral links and/or trailing arms just being done with.

Anything else that might be causing this?
 

·
Registered
Joined
·
89 Posts
I have an 04 wagon doing the same think. My rear-end makes it when I turn sharply or hit a bump. It started when I did some work on the passenger- side rear axle. I've checked everything. It makes a squeaky noise sometimes too....
 

·
Registered
Joined
·
2,663 Posts
I bet at least one of your solutions is something in the trunk moving around.
 

·
Premium Member
Joined
·
25,496 Posts
Remove the rear seat and drive around with someone in the back by the side making noise, if you can determine it is not the rear strut or spring, or helper spring making the noise move on to other things.. If it is a bushing it should be very visible as in.... MISSING.
 

·
Registered
Joined
·
380 Posts
I don't have anything in my trunk; mine only really makes the noise on a smooth, swooping bump if that makes sense. potholes and sharper bumps don't make the noise...Just when the suspension extends and retracts relatively slowly.
 

·
Registered
Joined
·
60 Posts
That almost sounds as if something isn't tightened down correctly. As if when it is being pulled from extending there is movement. With the new coil overs did you forget to tighten something down fully?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
sorry took so long to update this...have been troubleshooting it and making adjustments along the way..

...sigh its something pretty stupid actually.

The stock WRX muffler doesn't like the aftermarket Megan downpipe and the exhaust hangers are stretched to their max forwards (front of vehicle). Therefore the muffler is bouncing/rubbing on the sway bar/endlink. grrr
 
1 - 9 of 9 Posts
Top