ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,272 Posts
Discussion Starter #1
2005 WRX
Quick question regarding installing an aftermarket inlet regarding the PCV sensor and hose.
So the method of install is to just remove the sensor, jump the connector and plug the hose straight to the top inlet barb right?

And about this hose(marked in red):



I just had a valve gasket job done and now that I'm planning on swapping out the stock inlet I notice the damn hose is missing.... what hose is this(specifically) and whats the potential for engine damage?

Thanks!
 

·
Premium Member
Joined
·
6,501 Posts
Perrin should have the procedure on their website for thier inlet install for the PCV sensor. The other hose I don't know. My 02 only has one hose per valve cover and it's for the valve cover vents that go to the tube on the TMIC. That picutre look like it's from a 2.5L STI since I see yellow sidefeed injectors. It's supposed to allow for air into the PCV system.

 

·
Registered
Joined
·
1,272 Posts
Discussion Starter #4
The Perrin instructions were vague at best, to me.
But I just found what I was looking for, a picture says more than I can:
http://www.rspeed.org/forums/gallery/data/648/medium/IMG_1094.JPG
http://i4.photobucket.com/albums/y111/jheenoo/install1/stockout/IMG_4553.jpg
http://i77.photobucket.com/albums/j55/bcristea_photos/DSCN7957.jpg
http://i85.photobucket.com/albums/k46/FXLR8/bpvinlet.jpg

Yep, just take off the white sensor thing, jump the cable then plug it in directly.

As for that PCV hose thing, its weird, I know I had right above the inlet. But I checked the valve cover no longer has a place to put a hose. A newer setup by Subaru? I'll probably email the dealer that I went to.
Thanks!
 
1 - 4 of 4 Posts
Top