Subaru WRX Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
this is my first post/thread on here....ive been on and off as a guest to get a feel for the fourms...ok so heres my deal,

i drive a 2004 wrx, i live in upstate NY. recently when i start my car up from cold i hear this rattling noise as it revs up, once started it stops...i hear this noise again when accelerating around 3-3500rpms...its like i accelerate and then when i take my foot off the gas to put the clutch in i hear the noise again(no im not accelerating while the clutch is in)....the rattling doesnt happen if i park my car, turn it off for like 5 min and then start again(or when its warm), it seems to do it when starting only when cold and then when taking my foot off the gas and/or idling at 3-3500rpms...when i accelerate or decelerate the noise stops...its like if i slowly accelerate and its around 3-3500rpms i hear it faily loud, not sure what it sounds like outside, but in my car i can def hear it...

i took my car in to a subaru dealer to get looked at and they said it could be a lower end rod knock and said they would have to charge 700$ to take apart the engine and determine the actual problem. is this what i should do? should i get a second opinion, i dont want them to take my engine apart and then find out the problem was a loose screw or something like that or have them take it apart and have my extended warranty not cover the problem....i bought the car with 47,000 miles on it and i now have 58,000

please anyone with any ideas of what i can maybe do to solve or find out the problem myself or if anyone has had similar problems and could tell me what they think might fix it?
 

·
Premium Member
Joined
·
5,596 Posts
It could be anything from a heatsheild that's lose to some internal engine damage. If it's engine damage it probably wouldnt be RPM related to that extent or go away once it's warmed up.

I'd be it's a lose heatsheild or something banging around.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
im not sure if this helps, i had originally said that when it heats up the problem goes away...its correct in that it goes away when trying to start up and the engine when its already warm...but when im driving the rattling comes back usually with the lower gears when im around 3-3500rpms letting off the gas or idling the acceleration....i am going to check for the things you guys have mentioned, thank you!! if anyone else has any advice please help! thanks
 

·
Registered
Joined
·
3,793 Posts
does it sound like a rattling or more like a kind of mechanical grinding? For example, if you were to take off in 1st gear at a normal acceleration rate, shift to second, get to 3500 and then just take your foot off the gas and coast in 2nd, does it do it then?
 

·
Registered
Joined
·
108 Posts
possibly a turbo heat shield my lower bolt on the right side rotted and it gave a nice rattle when decelerating between shifts and upon accelerating from stop...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
i was just out testing out the sound since its fairly nice up here....again when the engine is warm the rattling noise does not exist....it is coming from the front left side, ive tried lifitn up the hood and listening for something, but everything sounds normal, at least to me...im going to try and upload a video and get the rattling on tape to better explain myself...ill try doing that sometime this week..

timdog - i was in 1st and shifted under 3rpms(did not make noise) and then went to 2nd and shifted and yes it does make the noise then, not sure about the coasting - its almost like its at a certain rpm, like if im goin lets say 40 and im in 3rd gear and im trying to idle it around 2750-3250 rpms(to hear hte sound) it usually does it around that time along with the initial cold start up...
 

·
Registered
Joined
·
3,793 Posts
I have absolutely no idea what that could be then...diagnosing noises over the internet is the WORST though....very difficult and only rarely gets you in the right ball park for what's wrong. Try to see if there's a member who is local who can drive it and listen for you.
 

·
Registered
Joined
·
2 Posts
I know this has been dead for awhile, but I suffer from the exact same problem. I have a 2004 WRX and I originally heard the noise and it was diagnosed as a loose heatshield. He said a simple trim would solve it. It worked, but only for a short while. Soon the rattling was back and getting worse. Again, I took it in (to someone different) and he said it was a loose heatshield. He mentioned that it was shaved down, but not removed. He apparently did the same thing, because now it has started up for a third time.

Would it be ok to just remove the heatshield? I've been told its not too important.

Hope someone sees this.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
okok the problem was a rod bearing......a few weeks ago my car just completely wouldnt run and i had to get it towed....turned out eth rod bearing went thru the housing and ****ed up my short block....luckily i had it covered under my extended warranty!!! who woulda thought! thank god it wasn't a hassel of a process as it could have been...i would recommend getting the problem checked to anyone who has the same issue....my noise is now gone and the engine sounds so much better - in the end i got a new rod bearing, short block, oil line, etc....worked out well for me in the end...GOOD LUCK to anyone who has this problem!! - get it checked!
 

·
Registered
Joined
·
2 Posts
okok the problem was a rod bearing......a few weeks ago my car just completely wouldnt run and i had to get it towed....turned out eth rod bearing went thru the housing and ****ed up my short block....luckily i had it covered under my extended warranty!!! who woulda thought! thank god it wasn't a hassel of a process as it could have been...i would recommend getting the problem checked to anyone who has the same issue....my noise is now gone and the engine sounds so much better - in the end i got a new rod bearing, short block, oil line, etc....worked out well for me in the end...GOOD LUCK to anyone who has this problem!! - get it checked!
I know you have an extended warranty, but did they quote how much something like that would have cost?
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top