ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
I just received my WRX back after the dealership replaced the EGT sensor on my uppipe. I am experiencing a different sound when going from about 2krpms to 4krpms or so. It sounds like a light flutter as i increase my rpms, and my turbo spooling seems to get this flutter as well. I am not noticing any type of performance issues, I dont have a boost gauge unfortunately so i dont know whether my boos has been affected or not. The sound isnt tinny, or sounding like detonation.

So i am wondering if while they were working ont he EGT they tightened down something more than normal, or less than normal and what it could be so i can check it out. I really dont want to take it back and let them have it for any more days, i was w/o it for two weeks. Thanks for any info.
 

·
Registered
Joined
·
1,038 Posts
I have this sound too. Noticed it after my downpipe was put in. I think it's just the turbo and you hear it more when freeing up the cats. You would know if it was leaking.
 

·
Registered
Joined
·
2,834 Posts
The "wastegate flutter" sound is normal after installing an aftermarket downpipe (especially with bellmouth and div. wastegate designs). However, I'm not sure why you'd be getting it after taking it to the dealership.

If it sounds like a plastic bag fluttering in the wind, then it is definitely wastegate flutter. You may want to search around for the thread about adjusting the wastegate arm. It's somewhere around here. I was getting a lot of flutter after installing my TXS Stealthback... After adjusting the wastegate arm, it's all but gone.

Good luck! :thumbup:


[EDIT]: Here's the thread. In the first post, there's also a link to a good thread on NASIOC about it.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #4
Yup thats exactly what it sounds like. Ive heard some ppl get this sound on brand new WRXs even. I just didnt want to melt my pistons or something if it was something else =D
 
1 - 4 of 4 Posts
Top