Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter · #1 ·
P0546 Exhaust gas temperature sensor circuit high input

Okay dosent this mean the EGT sensor is reading too cold?

I dont want to keep resetting my computer now that I have a UTEC...

The only time I get this cell is when im crusing down the freeway at +50 mile drives. It seems it always kicks on when im driving between 70-75mph..

Is the just quenidence? Or does it take a while for the EGT sensor to trigger a cell?

My upipe is a godspeed. (I never got this cell in autum) it started as soon as it got in the below 30 degrees, I must of reset my ecu 10 times already!

I Can turn off my check engine light with my UTEC now...But I wanna be able to see if I throw any other codes.
 

·
Moderator
Joined
·
1,263 Posts
Essentially - yes. Or your EGT prode is trashed.

I have TXS Stage 4 and have got it a few times, but not all the time. I checked the shop manuals on it and it calls a check of the sensor.

I think that the Cat in the up-pipe is a bit of a furnance and keeps the EGTs relatively higher than without.

I would get yourself an OBD-II scanner that lets you reset the codes without resetting the ecu. I hate driving around with the CEL on - you never know if there is another code 'lurking'

Cheers,

Andrew
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #3 ·
Do you know where I can find a RS-232 To OBD-II cable? I already have a laptop.. and i have seen software for like 30 bucks..

Hey it beats $150.00-$200.00 for a stand alone OBD-II scanner.
 

·
Registered
Joined
·
1,895 Posts
Have you thought about performing the 2.2kohm resistor mod for the P0546? Worked for me! :)
 

·
Registered
Joined
·
559 Posts
The resistor mod will be my solution if my EGT fails.
is2scooby,,i have a scoobysport full exhaust and i have a black box they call the cell fix,,but they say its for the downpipe,,they say the uppipe will not throw a CEL.
is that correct?
thanks
tuca
 

·
Registered
Joined
·
1,895 Posts
Not sure. I have a PDE uppipe that didn't throw the p0546 for ~3 months. Then it showed up one day - I threw the 2.2k ohm resistor in there and haven't looked back since. :)
 

·
Registered User
Joined
·
2,210 Posts
Biaxin said:
P0546 Exhaust gas temperature sensor circuit high input

Okay dosent this mean the EGT sensor is reading too cold?
Indeed. A high input means low EGTs, and as Andrew said this is probably due to removal of the pre-turbo cat having reduced temps a little.

I would try the resistor mod if I were you..

-Pace
 
1 - 10 of 10 Posts
Top