ClubWRX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
There’s a hose there that looks to be coming from the intercooler but connecting to nothing and there is a plug near it facing the same area not connected to anything. The hose doesn’t suck or blow anything out while the engine is running. Does anyone know what the part is? The car is a MY07 wrx sedan.
 

Attachments

·
Æternum
Joined
·
20,438 Posts
Forgive me, I don't see what you're seeing.
 

·
Premium Member
Joined
·
10,952 Posts
It's been a while since i looked at mine but if I'm not mistaken there is a secondary air pump in that area that seems to be missing. May be a left over from delete?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
It's been a while since i looked at mine but if I'm not mistaken there is a secondary air pump in that area that seems to be missing. May be a left over from delete?
Ah okay sounds like it could be it. Do you think I should be concerned it’s not there or is it unnecessary?
 

·
Æternum
Joined
·
20,438 Posts
Yep. Air pump.

Is there a CEL associated?

Sent from my SM-G960U using Tapatalk
 

·
Premium Member
Joined
·
10,952 Posts
I know that many of them had issues with failures and overheating. There was a recall and this was probably a fix.

I'd recommend finding an actual delete and remap for it, or replacing it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
I know that many of them had issues with failures and overheating. There was a recall and this was probably a fix.

I'd recommend finding an actual delete and remap for it, or replacing it.
Thank you. After googling and seeing how much a replacement is I think I’ll go with the delete. The bloke I bought the car off says his mechanic said he bypassed the air pump but that he’s not sure if it was actually deleted or just taken out.
 

·
Premium Member
Joined
·
10,952 Posts
The delete requires a way to tune the car if I remember. So have that handy unless the kit as a magical solution
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
The delete requires a way to tune the car if I remember. So have that handy unless the kit as a magical solution
Ah true thank you. The car has been tuned when the previous owner put a turbo back exhaust on, the pump could have possibly been deleted then before the tune although I’m not sure why they’d leave the pipe and plug there.
 

·
Æternum
Joined
·
20,438 Posts
If there is no CEL (as you have indicated), the ECU has been remapped.

Sent from my SM-G960U using Tapatalk
 

·
Premium Member
Joined
·
10,952 Posts
There should be delete kits that plate everything off so you don't have random hoses. Be nice to tidy things up
 
1 - 16 of 16 Posts
Top