Subaru WRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I bought a 05 wrx with a jdm ej205 in it last month. Motor has 60k on it.

When I plug a code scanner in it shows P0031, Front o2 sensor input low. And P0303, cylinder 3 misfire. I'm going to try and change the o2 sensor and the spark plugs.

The previous owner said that if I replace the o2 sensor the car would need to be retuned because it was dyno'd and tuned with a bad o2 sensor.

Has anyone else had these problems and any advice? Should I replace the o2 sensor anyway and get it retuned or not worry about it? The car seems like it runs pretty good.
 

·
Super Moderator
Joined
·
11,763 Posts
They tune with a wideband. I don't understand why you would not replace the sensor.

Also compression and leak down test the engine. Jdm engines are not always good
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 · (Edited)
I'm going to test the compression this week. I don't know why they would tune with a bad sensor either. It was tuned by precision motorsports in NJ. Tonight I cleared the codes and drove it around for a bit. P0301 and P0303 took about ten minutes to show up. I cleared it again and kept driving and no misfire codes showed for about an hour of driving, but eventually popped back up. Even though it says it's misfiring it runs and sounds great and I don't feel it misfiring. Also another thing I noticed is p0031 doesn't show up on my obd2 scanner, it only shows up on the cobb accessport. Could it be misfiring because I unplugged the battery recently? My other guess could be the tune just sucks. Lol now I know what people mean when they say buying a used wrx is a hassle.
 
1 - 3 of 3 Posts
Top