ClubWRX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hey guys ive been getting some pretty bad rev hang when up shifting (esp. at WOT). So today i decided i would take it off and cleaning it to get some hand on experience and see if that would help. Got some TB cleaner from autozone, and needless to say there was a huge build up behind the butterfly valve, it worked pretty well, havent installed it yet. I figured id go ahead and remove the intercooler and clean it as well. When i took off the y-pipe i could see a streak of oil residue in the right flange going down the curve. Im concerned this may be a turbo leak. I called 2 shops 1 said the same thing after i reported the symptoms, the other (mor familiar with boosted cars) said it was normal. What do you guys think?

IMG_20120223_120657.jpg IMG_20120223_120534.jpg IMG_20120223_120631.jpg
 

·
Super Moderator
Joined
·
33,822 Posts
The GS AOS has worked very well for me.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
So cleaning the TB made a huge difference. The rmps drop much much quicker than before now, but im still getting a slight pause before they begin to drop. Any ideas? Lmk if you need more info
 

·
Premium Member
Joined
·
15,697 Posts
Are you sure that pause wasn't there before? My car always seemed to have a slight delay and I thought it may be programmed in. I kind of like when the rpm hang a tiny bit if you are driving very spiritedly but not banging gears.
 

·
Gold Member
Joined
·
2,175 Posts

·
Gold Member
Joined
·
2,175 Posts
I'll be calling GS today to see what hoses these are.
 

·
Gold Member
Joined
·
2,175 Posts
I'll be calling GS today to see what hoses these are.

They said the hoses are made by Gates, but I can't find them anywhere! Ugh. Is it really that hard to find 1/2" and 3/4" clear hose that is suitable for fuel/oil use?
 
1 - 10 of 10 Posts
Top