Subaru WRX Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
Hi guys, I've done two oil changes on my car so far and both times the oil filter has leaked. I don't know if this is due to the brand of oil filter (penziol) I'am using or could this be another problem. I've done plenty of oil changes in my life and never had this problem, it's kind of annoying and I hate leaving oil spots:mad: Anybody else have this issue?

Thanks,
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #3 ·
What gasket, I never saw a gasket on the original oil filter that can with the car. I thought the only gasket that is used is the rubber one on the oil filter. I'am not talking about the drain plug here.

Please clarrify, I don't remember anything about a gasket in the user manual either for the oil filter. Plus wouldn't that get a little expensive if I need to replace a crush gasket at every oil change.

thanks,
 

·
Registered
Joined
·
3,501 Posts
dark_rex said:
did you also replace the crush gasket on the filter? i would suspect that is the problem.

dR
The crush washer is on the oil pan drain plug, not the filter.

Your leak might be caused by an imperfection in the filter mount, the threads might be crooked or the gasket surface might not be flat.

If I were you, I'd have the oil changed at the dealership and then complain to them when it leaks. Then they'll have to address the problem.

-Jim
 

·
Moderating U!
Joined
·
4,192 Posts
VERY IMPORTANT!!!!

I just changed my oil today and noticed that the FRAM oil fliter I used lost its rubber gasket when I took it out. I looked from underneath the car and saw that it had stuck itself to the upper flange of were it seals. Make sure that when your oil filter comes out that the rubber mating gasket is still installed on your oil fliter. Or you will have a BIG oil leak problem. And yes, I changed from FRAM to PUROLATER. I will never use FRAM oil fliters again. Thanks for the info in other posts.
Kurlee Daddee
(THE ORIGINAL)
 

·
Moderator
Joined
·
895 Posts
i used the purolater one and havnt had a leak yet

btw purolator is the same brand that Subaru uses
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #7 ·
thanks for the help

I changed the oil filter and I haven't had a problem yet. Must of had a bad one. Thanks for all your help guys.
 
1 - 7 of 7 Posts
Top