ClubWRX Forum banner

1 - 6 of 6 Posts

·
Good news, everyone!
Joined
·
3,856 Posts
Discussion Starter #1 (Edited)
CEL help please...

Okay so my engine has thrown 2 codes lately and I am thinking that it is because of my aftermarket exhaust. The ECU has thrown P0031 Front oxygen (A/F) sensor heater circuit low input, and P0420 Catalyst System Efficiency Below Threshold (Bank 1) codes. Now I think it is because of my replaced up-pipe (HKS), which actually has the bung for the EGT sensor. I have read about the 2.2k ohm resistor mod, but I don't think it will fix this CEL will it? What are your guys's suggestions?

edit*
List of mods:
Helix v.2 header
HKS up-pipe
Invidia Turbo back exhaust with bellmouth down-pipe
Perrin CEL fix (working)
 

·
Registered
Joined
·
2,599 Posts
The P0420 is because of your downpipe. It's telling you that your catalytic convertor isn't working properly. Nothing to worry about at all, and it can be fixed with either a PEP MIL fix or a mechanical fix.

The P0031 is similar, I believe, to the P0037 I thew, which was caused by a bad heating element in my rear 02 sensor. I'd assume the same thing happened to your rear. I don't know of any easy way to fix this, and I never did fix mine, as I was under the impression that it required replacing the entire rear 02 sensor, which is a pointless sensor. However, the front one is significantly more important, so you might want to look more into this.
 

·
Good news, everyone!
Joined
·
3,856 Posts
Discussion Starter #3
The P0420 doesn't worry me, but, I installed the Perrin CEL fix and made sure that it is working properly. So why would it still throw that code?

The P0031 code worries me somewhat, but I know that the engine isn't running rich at all because the exhaust smells and looks normal, no black smoke. I want to get an A/F ratio guage just to get an estimate on what the engine is doing. I don't think I can afford the wideband as of yet but I might. Thans for the help zoophagy. Any other opinions?
 

·
Registered
Joined
·
9,023 Posts
Your engine needs to go through something like 30 cycles before it loses a code. Try resetting the ecu.
 

·
Registered
Joined
·
300 Posts
While I can't speak with 100% authority regarding subaru's, I'm a nissan tech. A similar code on a new model nissan (p0031) would indicate a problem in the front o2/air fuel sensor heater circut. This circut is to help keep the sensor at it's optimal operating temperature so it can precisely control the mixture under closed loop. Usually this code would indicate an internal problem within the sensor heater element, or maybe an open wire between it and the ECU, which would be uncommon. As for the p0420, the catalyst inefficiency code, a CEL fix usually works pretty well, is the Perrin a mechanical type or electrical? Must be something wrong with the perrin fix, you already know there is a problem with the catalyst since some (or all) are missing.
 

·
Good news, everyone!
Joined
·
3,856 Posts
Discussion Starter #6
Yeah I am "missing" all of the catalytic converters on my car. The perrin manual says that if you turn the key to the on position without having the car running and the red light on the top of it is blinking then it is working. As for the o2 sensor do you think I should try to get a new one and see what it does or what do you think I should do about it?

Thanks everyone.
 
1 - 6 of 6 Posts
Top