Subaru WRX Forum banner
1 - 9 of 9 Posts

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #1 ·
Between chasing a misfire and an O2 code I've got some questions before I burn money on something that won't solve the problem.

My current code is p0140. This is the rear O2 sensor post cat if I have the correct info on the code as we don't have a sensor 3. Besides emissions what is there another function of this O2 sensor?

The front O2 sensor is behind the wheel well and not related to that code at all that I know of. If I understand it's purpose is reading AFR for the ECU for fine fueling adjustments. Per Cobb and Subaru the code I have currently is a problem and will cause AFR issues, but I don't understand how if it is for the sensor 2.

I'm going to get under the car this weekend weather permitting and look for loose connections, or chaffing of wires. I don't want to dump money into replacing the wrong sensor. Are there some other things I should look at to address this code?

The code only appears after a very long idle 10 minutes or so, and only when a stage 2 ots map is flashed. If I put the factory tune back on it on idle I get no code appear. Cobb thinks it's a faulty O2 and calling Subaru locally 1 out of 2 dealerships agree. The other says it's because of the aftermarket downpipe. My assumption is that should kick out a different code relating to the rear catalyst.

Any further information would be handy.

TL/DR:

What can cause p0140 O2 code, what should I check and what O2 sensor is it? What does each sensor do specifically?



Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Premium Member
Joined
·
12,314 Posts
Without looking back at your thread I can't remember the exact status of your car. You have a DP but what engine management (Cobb?). Personally with open source I'd just disable that CEL in the map and flash it back to the car, but I'm not sure if Cobb will let you do that.
 

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #3 ·
I have a catless downpipe as well as Cobb AP ots stage 2 tune. I'm aware of the overboosting possibility.

I do have access tuner, I'm not sure if I can disable that code with it or not. I gather from your response that my assumption is correct and that's a post cat sensor and shouldn't have an affect on the ECU other than emissions.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Premium Member
Joined
·
6,716 Posts
The rear O2 sensor is used for closed loop fueling corrections on 08+ models.. prior to that it was there for nothing other than to trigger a CEL in the event of catalytic converter inefficiency.



p0140 is described as "O2 sensor circuit no activity detected. Bank1 sensor 2", which is indeed the rear O2. The code for catalyst system efficiency below threshold is p0420. Since it's not throwing that code I would assume the problem isn't your downpipe. The fact that it's saying no activity detected leads me to believe that either the sensor is caput, or there is an issue with the wiring.

The first thing I would do is unplug the sensor from its harness, take a DMM and test both the 12v+ and ground wires on the harness with a DMM to make sure it's getting power and the ground is good. If everything there checks out I would then use the DMM and check the signal wire coming from the sensor.. first with the ignition on, engine off.. then start it up and see if there is any change. If there is indeed no activity coming from the sensor, then I would go ahead and replace it.
 

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #5 ·
Awesome, thanks. Supposed to be 60 and dry this weekend so should be fun.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Premium Member
Joined
·
12,314 Posts
Ah, I didn't keep up with the changes on the newer cars - sorry for the bad info.
 

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #7 ·
OK, so what advantage is there of the front and rear O2 if they are both serving the same function

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #8 ·
Let me rephrase that. I'm looking for the right denso sensor and they have the sensors labeled as AFR for the front and oxygen for the rear. I thought they both were just O2 sensors?

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Super Moderator
Joined
·
11,451 Posts
Discussion Starter · #9 ·
Just thought I would update here. I had no response from the signal wire so I'm getting a sensor from denso directly, if that doesn't work I guess i'll go to subaru, but I'm not down for a $200 sensor when denso sells it much cheaper
 
1 - 9 of 9 Posts
Top