Subaru WRX Forum banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
i-club has many reports of A/C units freezing up and causing problems. Anyone here having A/C problems?
 

·
Registered
Joined
·
50 Posts
I have experienced no problems with the AC. My car has ~ 2k miles on the clock. I have noticed that the AC appears to cycle on and off during use. You can notice a variation in the temperature of air coming out of the vents. I also noticed an occasional "frost" coming out of the vents. There is some mention of this condition in the owner's manual -- which indicated that the "frost" is normal.
 

Attachments

G

·
Discussion Starter · #6 ·
The A/C froze-up in my WRX twice in two weeks at about 3800-4000 miles. In both cases, the humidity was over 80%. I took the car to the dealer who found that the refrigerant was a little low. The dealer topped off the refrigerant and the A/C has been fine for the last two week, including days with high humidity.
 

·
Registered
Joined
·
50 Posts
Does anyone with an A/C problem have the optional dust/pollen filter? I wonder if the filter reduces the effectiveness of the system.
 

Attachments

·
Registered
Joined
·
211 Posts
I had my A/C lines freeze up after about 2.5 hours into my drive down to Kansas City this past week-end, but I had the A/C on full, and recirculating air. Basically the air stopped entering the cabin and was acting kind of weird...(saw the vapor too!) Had my girlfriend pop open the manual and it said it was normal under heavy load... which was very possible, not only did I have the A/C maxed, stereo blaring, but I had also been driving at 90-95 mph.... solution: turned off the A/C for 5 minutes, opened the windows, then turned it back on, it worked fine!

Oh, and it was over 85% humidity and 90 degrees out.....and no optional filter either...

[ August 06, 2001: Message edited by: Kenneth2000 ]
 
1 - 8 of 8 Posts
Top