Subaru WRX Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
When I'm by myself I usually don't let my car warm up in when it's cold out before I go for a drive. But with a baby I like to get it nice and warm in the car before we load up. For some reason though I run the heat full blast but nothing but cold air comes out of the vents. The only way to get warm air to flow from the vents is to take the RPM's above idle. Sitting in a freezing car holding the RPM's above idle to get it warm is not my idea of a $25,000.00 car. My stupid Honda (which was $10,000.00 less brand new) gets really warm without any intervention from me. I've tried different combinations of HVAC setting with no luck. Does anyone else have this problem? It seems almost like no hot coolant is flowing into the heater core due to a lousy/weak water pump.
 

·
Registered
Joined
·
314 Posts
I have noticed in my car that when its cold out, it blasts cold air until the engine is warm so that the fan can blow the warmed air into the cabin :)
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
Well, my car will warm up and the fan will even cycle on after it's reached operating temperature but no warm air blows from the vents. I kid you not, when it's freezing out and my engine has reached operating temperature I can still see my own breath inside the car with the air going full blast! I knew I should have gotten the Minivan instead of the WRX. :(
 

·
Hammerdown Mod of Thunder
Joined
·
23,890 Posts
I think you have a problemwith tour HVAc system. Zip back to your dealer and have them check it out.
 

·
Registered
Joined
·
488 Posts
josnroh said:
I think you have a problemwith tour HVAc system. Zip back to your dealer and have them check it out.
What he said... :)

Sounds like maybe the cable that moves the flap from "hot" to "cold" isn't hooked up. Or maybe your heater core isn't getting coolant.

At any rate, it's a warranty thing. Take it back.

Below zero this morning. My cabin was up over 70 degrees. The heat works in the WRX.
 

·
Registered
Joined
·
932 Posts
I just had exactly the same issue - the car would be blowing warm air and then I would stop at the lights and cold air would come out. I took it to the dealer and it was diagnosed as a low coolant level. They flushed and refilled the system and everything is now fine. However, they charged me $50 as I had aftermarket coolant hoses on and the low level could have been caused when I changed them, which is entirely possible, so I didn't argue with that.
 

·
Registered
Joined
·
1,629 Posts
Check your coolant level! It sounds like it's not reaching the heater core unless you rev the engine and force the water pump to send coolant.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #9 ·
Thanks for all of the feedback guys. I did recently have my radiator replaced under warranty and the level was pretty low. I filled the cooling system and bled it but it didn't really help. I did notice today though that when I had the blower speed at 2 warm air would flow from the vents but when I went to 4 it would get cold. After looking at the heating system diagrams in the cd-rom service manual (for educational purposes only of course) I would venture to guess that the cold outside air being drawn past the heater core at a high blower setting is too much air to heat and as a result feels cold. Screw it, I'll let the dealer deal with the problem. Thanks again everyone.
 

·
Registered
Joined
·
488 Posts
Do keep checking the coolant level in the radiator. You may have air bubbles that need to get worked out.
 

·
Registered
Joined
·
23 Posts
not enough heat

Definately time for a trip to the dealer. Don't waste another second on this yourself. Heat in my 02 WRX comes on very quick. Yours should too. M I N I V A N ??? ;)
 
1 - 12 of 12 Posts
Top