ClubWRX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
So I installed the Lightwerkz HID retrofit kit on my 11 WRX today. So far very satisfied with it, but now my driverside window doesnt roll down automatically, as in I have to hold the button down like the other three windows. Other than wiring up the HID kit and unhooking the DRL, nothing else has changed. Any ideas how this could happen? Thanks!

Sent from my SGH-T989 using Tapatalk
 

·
Registered
Joined
·
479 Posts
This happened to me the other day when i unhooked my battery to remove the C pillar with the airbag. I couldn't get the auto window to roll down with one push so I started to push all the buttons haha. What solved it for me was the auto lock window button (?), I engaged and disengaged it a few times and it started working again. Not sure if it'll help in your situation but its worth a shot. Good luck.
 

·
Captain James of the SS Impreza has gone down with
Joined
·
8,921 Posts
Your first mistake was installing HIDs.
 

·
Registered
Joined
·
2,136 Posts
Anytime I disonnect the battery for a period of time, my auto down and auto up stop for a few hours, they always come back so I suspect you just need to give it a little time and they'll work again.
 

·
Registered
Joined
·
2,663 Posts
Your first mistake was installing HIDs.
Basing on him saying he got a "lightwerkz HID retrofit system" then it was a great idea. If he did just throw in a HID kit without upgrading projectors then yes, mistake
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
Basing on him saying he got a "lightwerkz HID retrofit system" then it was a great idea. If he did just throw in a HID kit without upgrading projectors then yes, mistake
Thank you. I put that in there in hopes this wouldnt become a "oh I dont like something so its stupid" thread

Sent from my SGH-T989 using Tapatalk
 

·
Registered
Joined
·
2,663 Posts
so you did in fact do a retrofit with proper projectors though correct?
 

·
Registered
Joined
·
2,663 Posts
good choice. Also, seems like you got your answer on the windows. Let us know if the issue doesn't go away after a while.
 

·
Registered
Joined
·
2,663 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #13
Normally its $300 from Lightwerkz but they had a 25% off sale for Black Friday so it brought it down to $225. Def not as cheap as ebay kits but they look nice!

Sent from my SGH-T989 using Tapatalk
 

·
Pro Manscaper
Joined
·
21,455 Posts
Your first mistake was installing HIDs.
I swear you are turning into the new Brfatal.

I haven't heard a positive post from you in forever! You need a real attitude adjustment Jimmy!
 

·
Registered
Joined
·
67 Posts
Discussion Starter #16
Ha ok it started working tonight. Didnt do anything, just came out from work and it was working. Guess it just doesnt like being unplugged!

Sent from my SGH-T989 using Tapatalk
 
1 - 16 of 16 Posts
Top