ClubWRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hey i just got an 02 wrx that already came with some upgrade, the sti turbo, sti top mount intercooler jdm fuel injectors, monomishu racing raditor, spt intake and 3in catless TBE, also the up pip had been gutted. i installed a boost gauge on it and a Forge BOV, i has having a stange noise coming from the turbo due to it is only bosting at max 10psi. the car has a XPT open source tune on it and i was hoping to be able to up the boost via reflashing the ecu. the spring in the BOV currently needs 15psi. is it possible to reflash ecu to boost higher? and with whats been done do you think that the block can handle it? please let me know!
 

·
Premium Member
Joined
·
25,496 Posts
remove the BOV. If you still have the problem, look for a leak.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
i did remove the BOV and i still only boosted ten. i thought that it was my gauge so i used a pressure tester on it and my gauge reads correctly. so i figures that when the tune was installed on my car that they set the stock boost controll to 10psi. i want to replace that with a mechanical one if i cant go in to my tune and change the boost settings. is that even possible? also i did some reading and i "bleed" my wastegate line and now im getting 14psi but im still looking to boost 15-17psi for my BOV. any other suggestions? deffently need all the info can get
 

·
Registered
Joined
·
4,002 Posts
Check your turbo inlet tube that connects to your turbo. If its factory, they're known for eventually having a crack in them over time. I'm only saying this since you hear air coming from that area.
 

·
Premium Member
Joined
·
6,501 Posts
The restrictor pill could be missing from the turbo vacuum line.
 
1 - 5 of 5 Posts
Top