ClubWRX Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hey I'm new to the forum. Just bought a 05' WRX.

Picking it up tomorrow. I used to drive a mazda protege, then a 07 corolla, then a 07 civic si, now a WRX.

I'm from orange county NY, So I'd like to go to some meets and stuff.

Idk what my first mod will be. The car already comes with a boost guage, So thats out of the way. I'm thinking cobb access port but I have to a little more research.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
cool. But I dont think Im gonna buy any pipes or anything yet. I just wanna get the cobb
 

·
Super Moderator
Joined
·
33,822 Posts
Greetings and welcome to the Club! :wave:
 

·
Registered
Joined
·
966 Posts
welcome to the forum! im in Bergen county NJ, theres meets at IKEA in paramus every saturday night, ill roll wit you if you want just lemme know!
 

·
Registered
Joined
·
36 Posts
Discussion Starter #13
thanks for the welcome guys! I should have mentioned I have a temporary liscene so I have to wait 6 months until I can go wherever I please lol. Got into some trouble with the law. :unhappy:

Actually, I have a few minor issues with my car I didnt notice when I picked up the car...The sides have a few dings from other drivers opening their doors into them.

Also the dash is a little shot. I'm looking to either replace it or put a dash trim to cover up some scuffs and things. As well as the shifter is a little worn, Want to replace that as well.

Any suggestions? I also noticed on the boost guage that came installed on the car, when I'm driving it shows the level at like negative level? ill take a picture of it soon. Idk if its supposed to be there. Already got issues lol.
 

·
Master Baiter
Joined
·
22,114 Posts
Browzer said:
I also noticed on the boost guage that came installed on the car, when I'm driving it shows the level at like negative level? ill take a picture of it soon. Idk if its supposed to be there. Already got issues lol.
Normal driving, it should stay in vacuum. It should only be positive when you're pushing the car or driving uphill.
 

·
Registered
Joined
·
27 Posts
Ya from what my brother was saying driving mine home. Mine does the same thing, stays in the negative until the boost kicks in. I also have some work to do to mine seeing as the 18 yr old kid that owned it before me apparently didnt know how to take care of a car. So now I am dropping about 2 grand to my buddy and his shop to get it all where it's supposed to be.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #17
any of you guys know what I can do if my remote unlock thing doesnt work? i tried another battery, but it didnt work so Im gonna buy a new one and see if thats the problem. if not is there a way i could use an old one from a different car or am I dealer bound?
 
1 - 17 of 17 Posts
Top