ClubWRX Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I’m new here but do have somewhat of a pretty technical background in automotive and engine tuning. I have a 02 Impreza that I traded a truck for from my wife’s step dad non running at the time (pretty sure old engine is still good, but thats off topic). I finally decided it could use a new engine so I had jdm motors out of Dallas install a low mileage “jdm” 2.0 for me because they have a warranty behind it and I plan on selling the car possibly. So here’s the tricky part, I’ve driven it a little bit knowing it needed an O2 sensor and the butterfly things in the intake (excuse my lack of better terminology) were also needing to be replaced from what they told me. I do dumb things sometimes but with the intent and enough base knowledge usually not to break stuff so I put a good bit of octane booster in with my full tank of 93 before I drove it any since it should at least need a tune after I fix the other issues because if I’m correct the jdm engines were a little higher compression. Anyways I accidentally blew the blow off valve return hose off the first time I got er loose on some gravel and let the rpms get away from me a tiny bit lol. So I thought I fixed it enough to at least drive it to the gas station by removing the return hose completely and plugging the part of the intake it returns to. I have the bov in the vent to atmosphere position now and it is making boost there at least enough for me to think I’d see positive pressure on my gauge but I’m not and the car is running just as bad if not worse than when I blew the hose off and limped it home 😬 any help would be greatly appreciated
 
1 - 1 of 1 Posts
Top