Subaru WRX Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
So i just got a new engine built in my 09 wrx, mahle 4032 pistons, manley rods, acl bearings. sti crank, and all that good stuff. And i dont know if its random sensor noise or not. But sometimes knock sum on cyl 4 goes up maybe to like 15-20 ish in a 10-15 min drive and sometimes it will only see 1 after like 40 min of driving (running no boost for my break in). All others are at 0 and fine knock learn is at a constant 0 as well as feedback knock at 0. DAM also stays at 1 constant. What i noticed in my logs is once in a while Injector duty will go to 0% for a few lines and thats when the knock on 4 happens. Usually when i let off the throttle as well. But i mean this value will go up sometimes even if im sitting in one spot in neutral and i revv it a bit, ill see knock on 4.

Any ideas? Bad injector? Should i worry?

if needed i can upload a log.
 

·
Super Moderator
Joined
·
10,921 Posts
It depends entirely when the knock is happening. If it's at idle I could be false knock. Have you checked that plug and coil?

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
it happens at random, at idle, giving it a bit of revvs from idle on neutral, while driving, while shifting. I do get a random misfire CEL for 1 and 3 at random sometimes maybe happened like 3 times in the last 600km. But plugs are new (step colder) and the coil pack on cyl 1 is brand new as well.

https://docs.google.com/spreadsheets/d/166OrXo-H8iwYw4EGwiFqtlUzRystiSVfnPz2vWSxdIQ/edit?usp=sharing

Btw this is no boost and no crazy pulls as im still in the break in period

I don't think the Knock Sum is a total bust on the ap. When i spun a bearing on my old motor i decided to try and drive it to my mechanics with the knocking because i knew it was screwed anyways. I logged my drive and my cyl 2 with the spun bearing knock sum was going up like mad. Surprisingly fine knock learn and feedback knock stayed at 0 almost the whole ride until the motor sized.
 

·
Registered
Joined
·
142 Posts
Go talk to the person that built or tuned your engine and relay your concerns. You paid them for their service and it should continue after the install
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Im going to see a tuner tomorrow to get a better more custom breakin map. Ill ask them. And if they dont have an answer ill ask the build shop when i go for my final breakin oil change next week.
 

·
Super Moderator
Joined
·
10,921 Posts
Some of it may be piston slap if the ptw clearance is large.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Super Moderator
Joined
·
10,921 Posts
That's tragic and I'm sorry to hear it. Hopefully you can get a resolution that doesn't cost a fortune

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Banned
Joined
·
289 Posts
Ouch..good luck, hopefully your builder warranty's it.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #14 ·
Motor is out and a possible issue to this was the weld from the FMIC BPV flange broke and piece of it got sucked in to the engine. But i been seeing lots of knock and hesitation when letting off the throttle from day one and feel like if that was the cause the engine wouldn't have lasted 2300km. Might of been a coincidence as a few days before the tune i remounted the FMIC core tight and snug and all the piping as well and after market engine mounts and pitch stop. And the pipe with that flange was resting on the oil cap fill tube where it might of got alot of vibrations from the engines causing the weld to go.

Machine shop is going to inspect the block further once the block gets ripped apart.
 

·
Premium Member
Joined
·
7 Posts
Motor is out and a possible issue to this was the weld from the FMIC BPV flange broke and piece of it got sucked in to the engine. But i been seeing lots of knock and hesitation when letting off the throttle from day one and feel like if that was the cause the engine wouldn't have lasted 2300km. Might of been a coincidence as a few days before the tune i remounted the FMIC core tight and snug and all the piping as well and after market engine mounts and pitch stop. And the pipe with that flange was resting on the oil cap fill tube where it might of got alot of vibrations from the engines causing the weld to go.

Machine shop is going to inspect the block further once the block gets ripped apart.
Let us know what you find. You should not be hearing piston slap if the block was machined with the prescribed clearance, so make sure and get those bores checked.
 
1 - 15 of 15 Posts
Top