ClubWRX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Just went and test drove this car:

2002 Subaru Impreza Wagon WRX Sport New Timing Belt & Water Pump!!

Dealership says the timing belt, water pump, tensioners, idler and thermostat were all done. Spoke with the mechanic who did the work and he said there was a leak coming from the water pump and that's why they just did everything. On the test drive I noticed that the temp gauge **** up (not to red) but close. Went back to the dealership and I noticed that the coolant level was at e and they put more in. Did not overheat after that but im wondering why this shot up? There is no white smoke coming out the exhaust and I am having a Subaru dealer doing an inspection tomorrow. I did not notice any leaks but just want to make sure it's not burning coolant! Kind of bummed out here because this is still a very nice car! What do you guys think?
 

·
Registered
Joined
·
2,136 Posts
Sounds like air in the system, these cars can sometimes be difficult to bleed. If it stays normal I would say that you are OK.
 

·
Æternum
Joined
·
20,598 Posts
My guess is that the mechanic flushed the coolant and didn't burp the system correctly when adding coolant back into the system. You can burp it yourself, but I would take the car back and insist that the mechanic do it correctly; it's unacceptable that they would give you the car back without the proper procedures IMO.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Just dropped the car off at Subaru. We will see what they say! On the drive there which was about 20 minutes the car didn't over heat.
 

·
Pro Manscaper
Joined
·
21,455 Posts
you're positive that the timing belt has been done? Doesn't say that anywhere in the carfax. Just want you to be careful of that
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
Positive on that but having the dealership check in to it as well. I talked to the mechanic who also did all the work and showed me all the old parts.
 

·
Pro Manscaper
Joined
·
21,455 Posts
Ahhh that's good. Otherwise it looks to be in great shape with a great maintenance history where everything appears to check out nicely. Very clean and stock at a pretty damn good price as well.

If final checks work out...you found a gem.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #11
I am just hoping that when the Mechanic did all the work he just didn't properly fill the cooling system and subaru just has the redo it! Fingers crossed because if it fails inspection. I don't think I will buy it :( dealership said that if it is the headgasket it's $2200 + !!!
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
Final verdict from Subaru:

COMBUSTION FUMES IN COOLING SYSTEM
REAR BACKING PLATES RUSTED
REAR WASHER HOSE LEAKING
LOWER ENGINE NOISE
POSSIBLE HEAD/BLOCK WARPAGE
POSSIBLE HEAD GASKET LEAK

After speaking with the dealer he NOW states that the reason they did the waterpump was because the car was overheating when they got it! So they lied to me (no surprise here) about doing the water pump because it was leaking. Subaru tech gave me the most likely scenario:

The dealership got the car and they noticed that it was overheating, that is why it has a new thermostat. The dealership noticed that this didn't fix the issue and decided to do the waterpump and replaced the timing belt and tensioners all at once. The dealership might have thought this fixed the issue or just tried to pass it off because they know how much work doing the headgasket is and didn't want to put any more money into the vehicle! Needless to say I did NOT purchase the vehicle! The search goes on!
 

·
Registered
Joined
·
20 Posts
Discussion Starter #13
Thanks for all of the help guys! I WISH it would have just been air in the system because this car was CLEAN!
 
1 - 13 of 13 Posts
Top