ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Just went and test drove this car:

2002 Subaru Impreza Wagon WRX Sport New Timing Belt & Water Pump!!

Dealership says the timing belt, water pump, tensioners, idler and thermostat were all done. Spoke with the mechanic who did the work and he said there was a leak coming from the water pump and that's why they just did everything. On the test drive I noticed that the temp gauge **** up (not to red) but close. Went back to the dealership and I noticed that the coolant level was at e and they put more in. Did not overheat after that but im wondering why this shot up? There is no white smoke coming out the exhaust and I am having a Subaru dealer doing an inspection tomorrow. I did not notice any leaks but just want to make sure it's not burning coolant! Kind of bummed out here because this is still a very nice car! What do you guys think?
 

·
Premium Member
Joined
·
10,943 Posts
If it had a leak it likely over heated, especially since the car lot has been running it without coolant AFTER changing the water pump. How many other people have driven the car without coolant, and how hot did it get? That's what I would be worried about.

I would stay away from the deal. At the very least I would think it's going to need new head gaskets, if not a new motor down the road. Over heating just once can ruin an engine.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Dealership said they noticed a leak that appeared to be coming from the water pump area. My thoughts are: when they did the water pump and thermostat did they fill the system properly and is there air in the system? It overheated for maybe like 30 seconds then went right back to normal temp. Everything I have read online points to air in the system especially since it got hot then went back to normal. Idk I guess I will have to see what Subaru thinks tomorrow?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Final verdict from Subaru:

COMBUSTION FUMES IN COOLING SYSTEM
REAR BACKING PLATES RUSTED
REAR WASHER HOSE LEAKING
LOWER ENGINE NOISE
POSSIBLE HEAD/BLOCK WARPAGE
POSSIBLE HEAD GASKET LEAK

After speaking with the dealer he NOW states that the reason they did the waterpump was because the car was overheating when they got it! You hit the nail on the head MainFrame! This sucks because the car is super clean but I am much better off knowing that I didn't spend $8300 on something with major issues! The subaru tech basically told me to run!
 

·
Premium Member
Joined
·
10,943 Posts
Yeah.. I would guess that the engine needs to be rebuilt, the heads and block probably should be decked, etc. Probably around $3,500 to fix it.
 
1 - 7 of 7 Posts
Top