ClubWRX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,525 Posts
Discussion Starter #1
*background* Since having front end body damage fixed my brake and battery lights on the dash flicker when at WOT but everything has seemed fine. :eek:

Today my wife and I decide to take my parents up to Mt. Hood and though the Gorge. Just as we're about to turn to go up to Timberline my tach and speedo go to zero and keep bouncing up and down, my wipers slow down, and the last number on the clock goes dim. At first I'm thinking alternator but the car never lost any engine power just electrical. When I turned my headlamps off it immediately stopped and didn't do it again until I turned them back on so I just left them off.

Well, when we left the lodge and headed down it was foggy so I turned my lights back on. Just up the road towards Hood River it started freakin out again but this time turning the lights off didn't help and the car also stumbled a few times. (While some guy was riding my bumper in an older AUDI :rolleyes: ) Finally we pull over and I checked under the hood for any visible loose connections. At this point all I was thinking was $$$ for a flatbed. We kept going with the lights off and it never did it again the rest of the way.

I was pretty sure it had to do with a bad ground, alternator, or my morettes until I read this thread...

http://www.clubwrx.net/forums/showthread.php?s=&threadid=76744

It WAS raining the entire day...maybe water on the headlamp connections...:confused:

Any ideas??
 

·
Registered
Joined
·
22 Posts
My car had those exact same symptons...but mine went about 2 more blocks from when those symptons happened and completely died. Had it towed to the dealership and they said the alternator went bad (low output).

My tach flickered on and off, my stereo turned on a off a few times, my ABS light came on, lights dimmed, heard some clicking electrical noises and by that time I was thinking what the hell and then it died (in the middle of an intersection I might add). My guess is that your alternator is going. My alternator was still functioning, albeit, less output than normal but not enough to run car at that moment since all the juice in the battery was used up. I would at least get it checked out.
 

·
Registered
Joined
·
1,525 Posts
Discussion Starter #5
This morning I checked the airbox and MAF and you could tell that it hadn't been wet inside. I'm leaning towards alternator because when I pulled over it actually seemed to run smoother as soon as I grabbed the wires on the alternator. Either way it's going to get checked out ASAP.

It is possible that it could be drive belt related but the accident was very light and only cosmetic. However, I do think that the body shop is responsible because one of my fogs didn't work, the guy who detailed it rubbed the paint off the inner fender, the alignment was jacked up, and a few other things have also been screwy.
 

·
Registered
Joined
·
342 Posts
thats funny because i had an almost exact experience yesterday while i was at burger king's drive thru...i switched to my d12 cd...then i put up the volume a bit and the rpm's dropped to 0 and the cd stopped playing and the interior lights started dimming... i turned off the radio then back on and it stopped but it freaked me out... im guessing it was just a glitch :( do you guys think its the alternator? if so then i guess ill have to buy a new one :mad:
 

·
Registered
Joined
·
498 Posts
i vote alternator, i had the same problem with one of my other cars.
 
1 - 9 of 9 Posts
Top