ClubWRX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I just upgraded with a new turbo-programmer-cold air intake-exhaust.. It starts up and shuts itself off after a second.. Any ideas?
 

·
Premium Member
Joined
·
15,697 Posts
The turbo programmer is set up wrong or malfunctioning.

You don't need it, remove, sell or return.
 

·
Good news, everyone!
Joined
·
3,856 Posts
Turbo programmer? The hell is that?
 

·
Æternum
Joined
·
20,568 Posts
More like downgraded...
 

·
Registered
Joined
·
4,033 Posts
yeaaa......remove the turbo timer, get a tune for your other mods.
 

·
and the Funky Bunch
Joined
·
6,124 Posts
Well I didn't get a turbo timer I just upgraded and got the amrcxr 500.
Ahhh, so your original post should be read like: "New turbo, programmer, cold air intake, and exhaust." Gotcha.

So what do you mean by "programmer?"
 

·
Registered
Joined
·
4,033 Posts
I'm sorry, so you just slapped on a new turbo with no other supporting mods?

What's a programmer?...

So far I have that you put on a turbo, programmer(wth is that?), intake, exhaust.

If you put on another turbo, you need other mods to support it, and please explain what a "programmer" is.
 

·
The Member
Joined
·
4,146 Posts
It probably won't start because you aren't getting enough fuel to power that new turbo. Never heard of the turbo you put on so this is just a guess.
 

·
and the Funky Bunch
Joined
·
6,124 Posts
I understand why he got a new programmer, this was the old one...

 

·
Æternum
Joined
·
20,568 Posts
It probably won't start because you aren't getting enough fuel to power that new turbo. Never heard of the turbo you put on so this is just a guess.
doubtful. He's not boosting at idle.
 

·
and the Funky Bunch
Joined
·
6,124 Posts
Who did the turbo installation? Possible vacuum leak or something along those lines (pun intended)?
 
1 - 16 of 16 Posts
Top