Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I bought the car a couple of days ago and it's doing the boost creeping/lurching problem I've seen alot of people have. So far I've replaced the crank position sensor and put a upgraded walbro 342 in it. The car doesn't start some days to I know that sounds crazy but it wouldn't start for 2 days and just for "****s and giggles" I tryed today and it fired right up. The motor sounds great not noises except the soft lifter tick all of them have. It runs great if you dont give it full throttle and It starts lurching around 4 grand. AFR'S are pretty decent its (14.2-idle) and closer to high boost 4 grandish its drops to 11.6
I'd really appreciate any help or knowledge someone could give me about this.

Edit*** it runs about 21 pounds and has a perrin stage 2 tune
 

·
Super Moderator
Joined
·
10,960 Posts
You want your afr under load lower.
 

·
Registered
Joined
·
427 Posts
No shots fired but I think you need more seat time than few days before you "know" a car has a problem. Look at symptoms, issues, whatev and think about ALL of the possible issues that could be causing that. Bounce it off the forum, some mechanic buddies and then start swapping parts. Boost creep on an 02? I've not really heard much about that. Boost creep on a TD04 means you're on meth or something better, on that note..share.

Your tune might need looking at. I'd get as much info as possible from previous owner. Most importantly who did the tune and if they have a copy of it. Tune could be whack even if they said it was a "Perrin" or "Cobb" tune. Only proof is looking at it.
 
1 - 3 of 3 Posts
Top