Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone, so I have this issue with my 2017 WRX. My check engine turned on last month along with the ABS/Hill Assist/Traction lights. I took it to go get it serviced and they said that oil was leaking into the camshaft and they replaced the whole thing including the ECU thanks to warranty. It took them almost three weeks to service the car and when I got it back, not even 24 hours have passed and the same lights turned back on. I haven’t taken it to go get it serviced because I need the car to commute to work. Has anyone else had this issue?
 

·
Super Moderator
Joined
·
10,883 Posts
Without the code nobody can really say.
 

·
Registered
Joined
·
1,191 Posts
You're going to have to take it back to the dealership. It sucks, but if you mess with anything yourself you may have some warranty issues.

Before you take it back to the dealership CALL THE SUBARU OF AMERICA HOTLINE and tell them about the issue. They'll get in touch with the dealership and bird dog any repairs. They will also help you set up an appointment. Be polite, because they certainly will be.

SOA is extremely helpful and sometimes they award compensation, even in the form of gifts. They sent us a new Sony Soundbar and a couple hundred dollars worth of service coupons without us asking for anything, not that it was our intended goal, but it really impressed us. They also awarded me $4,000 toward a new STi, because of ongoing suspension issues, but you won't have to go down that road. Those were extreme circumstances. The dealership won't give you a loaner? If not, ask SOA after telling them about the previous lengthy repairs. Hopefully, you're not modded.

Good luck. Keep us posted.
 
1 - 3 of 3 Posts
Top