Subaru WRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey guys,

I drive a 2012 wrx. Earlier I had a a question on whether or not I should clamp my BOV return hose coming off the inlet and I have since done so. I posted that before I even drove it around. After installing Perrin turbo inlet I can't seem to pull more than 11 lbs of boost in any gear (tune set to max at 15.5 in 1st, 16 in 2nd, and 18 on). I made sure all of my connections are snug and everything that needs to be clamped is. I have checked all couplers on FMIC, all vacuum lines, sprayed soap water around all valves and hose connections to test for boost leaks. Nothing. The only difference I see before and after my install is that my AP reads fine knock learn at 0 no matter how much I step on it (used to max at around 2.8 whenever I built peak boost). Is there something I can check in my Access Port to see what's going on? Do i just need a retune?

Thanks!

Zach
 

·
Master Baiter
Joined
·
12,649 Posts
Pressure test the intake tract
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Do I have any other options? This would definitely be more than meets the eye as the spigots are VERY difficult to get to with this model year. I mean I suppose I could just pinch the hoses with some surgical vice grips but that would probably rupture the hoses. Is there anything I can see in my Access Port to verify if I actually do have a vacuum or boost leak?
 

·
Premium Member
Joined
·
12,314 Posts
Is the restrictor pill back in the correct line?

You can look at the a/f learning for some indications.
 

·
Premium Member
Joined
·
6,716 Posts
Do I have any other options?
You can look at the a/f learning for some indications.

^This.. if you have a leak it should show up in your A/F learning numbers. Although, previously the only way to pull up the learned values stored in the ECU with an AccessPort was to hook it up to a laptop with Access Tuner Race installed. Now you have to pay and take a class before you're allowed to download ATR so I'm not sure how people are supposed to get to Cobb's rendition of Learning View.. or be able to log a WBO2 for that matter. Those are the two big problems I see with them restricting access to ATR.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I never moved the pill so it should be. I will check my A/F learning. Anything specific to look for when reviewing the output?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Results at the end of my ride home from work -

PSI - -11.98/10.27
AF Learning 1 - -9.38/3.91
AF Learning 1 C - -9.4/-4.4
AF Learning 1 D - 0/0

I did 3 4th gear pulls from 3500-5k RPM. Max AF learning could be seen when idling. Minimum could be seen during pulls. Thoughts on these results? I'm no expert but they don't seem too terrible other than the low boost. Another thought too - Is it worth checking out my MAF sensor or is that unrelated to my issue?

Thanks,

Zach
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 · (Edited)
Still an issue. Any ideas fellas? Issue appears to be getting worse, unable to pull over 8 lbs now as of a week ago. I have since stopped doing pulls so as to not break anything.
 

·
Premium Member
Joined
·
6,716 Posts
Still an issue. Any ideas fellas? Issue appears to be getting worse, unable to pull over 8 lbs now as of a week ago. I have since stopped doing pulls so as to not break anything.

Who tuned the car, and what do they have to say about it?


Did you ever get around to performing a boost leak test?
 
1 - 12 of 12 Posts
Top