Subaru WRX Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Well I’m back..... I just received my APV3 for my 2002 wrx, I flashed to stage 2..
Mods are TBE/up pipe
Intake
My car was running roughly 10lbs from the get GO... after reflashed I am now running 6/7lbs which is nooooo bueno... Any ideas of where to start I can’t find no vacuum leaks... it holds steady 6lbs and does not drop like it’s set for it or something?? My MBC when adjusting the turns it literally does not move the boost...

My concern is this right next to my driver side door panel I have a Clicker 1/10 it’s set to 4... when I purchased the car the guy said just leave it on 4 what ever the he’ll that means I have no idea what this dude has going on but when I switch the clicker to any other number it kills the car? AS if it adjust the timing or what not or who the heck knows... Any self remedy’s I can try before I take this to the shop and they rape my $$$ Thanks in advance guys!
 

Attachments

·
Super Moderator
Joined
·
10,884 Posts
I wasn't aware any of Cobb's tunes worked with a manual boost controller.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Oooh shucks.... Ok thanks guys.. I will have to hold out on A OTSM for quite some time until I get bills straight my girl isn’t too happy lol.... . I will be looking into a EBCS any recommendations thanks!!! I’m just looking to run stage 2 as I have all the requirements.... I know pro tune is way to go for reliability and also performance but just can’t fit it in right now...
 

·
Registered
Joined
·
66 Posts
Oooh shucks.... Ok thanks guys.. I will have to hold out on A OTSM for quite some time until I get bills straight my girl isn’t too happy lol.... . I will be looking into a EBCS any recommendations thanks!!! I’m just looking to run stage 2 as I have all the requirements.... I know pro tune is way to go for reliability and also performance but just can’t fit it in right now...
Not sure the AP will work with a boost controller of any type. Call Cobb (866) 922-3059, I have spoken with them several times and they are very helpful and know thier stuff, most of them drive Subies or Focus RS's.
 

·
Æternum
Joined
·
15,466 Posts
1. Are we sure that it's an MBC?
2. Take a picture of your engine bay focusing just below the Passenger strut tower.
 

·
Æternum
Joined
·
15,466 Posts
Cobb is just going to tell you to run exactly the modifications listed in the map notes.

Unless you are willing to get a custom tune, your best option is to install an OEM boost controller and restrictor pill
 

·
Registered
Joined
·
66 Posts
^ what he said.

That or get a protune. Check around, you might be able to find someone who stalks a forum and is willing to tune it via datalog. Wont be as good as a dyno or street tune in person though....in most cases.
 

·
Æternum
Joined
·
15,466 Posts
^ what he said.

That or get a protune. Check around, you might be able to find someone who stalks a forum and is willing to tune it via datalog. Wont be as good as a dyno or street tune in person though....in most cases.
And that's fine, but these days Cobb requires you to pay $200 for a copy of AccessTuner Race. Well technically, you are "paying" for the online training tutorials that they claim is for "liability" reasons. That's BS though -- if that were the case let us take the test first and if we pass, give us a copy of the license.

I respect Cobb's business model, but as a consumer I loathe what they have done to anyone wanting to get their feet wet.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
Update* I have got the MBC set it was running 18/23lbs spike which it hit that twice... I realize the spike is horrid so I stoped getting on it...
When I accelerate the throttle too quick the boost was lay it out all the way open since my Wastegate is 100% open on the actuater... so I had to slowly throttle it and it would pull like a train.... only had this on for one day.... Now my car drove great this morning and I parked and when I went to leave again my boost reading was the same but the difference was it was not pulling what so ever as if I had some kind of leak??? But I cannot find any
When I jump in throttle or even peddle it slowly my boost would jump to -7 to 4-10-14-20 so quickly but the scary thing is my rpms were still 2200/3k So LOW to be pulling boost like this... anyways my car spoils up Exessive blow off sound noise when I just touch the throttle and it builds in .5 seconds and pulls maybe 2/3MPH I’m so lost I’m taking it to the shop tomorrow hopefully I’m not to technical when it comes to cars but it doesn’t seem healthy... just confused on how few hours ago it ran GREAT and now it’s like I’m boosting and not pulling what so ever... just confusing cause my boost gauge is reading accurately to my accessport.. I seen recent post on vacum leaks etc but figured I’d inform you guys.... one thing is when I stay on the throttle and ride it out it kicks in and out as if it was some kind of leak etc somewhere just curious cause it ran GREAT and I parked 30 mins later suddenly this it don’t make sense......

Sorry for run on sentences it’s late I been brain storming with car just irritated cause I think it’s something simple and I can’t afford 500$

pS thanks so much for input ^^ go figure I get the boost I wanted and now she’s pulling 0 basically lol...
 

·
Super Moderator
Joined
·
10,884 Posts
Man it isn't as simple as you've got this in your mind. The mbc isn't doing you favors and your current path is likely to prematurely damage something.

You need to contact Cobb and find out what they have to work with your setup, or take all of that back to factory stock. What you are describing (as I fill in blanks with assumptions) isn't normal for operation.

Yes your engine should build more boost under a higher mechanical disadvantage. So low rpm high throttle, however it should not do this in lower gears like first or second. You also should be meeting your boost targets in the map you run, and I don't think Cobb targets 20+. Low and slow throttle engagement shouldn't provide much boost either.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #13 ·
Another update lol....
MBC is off the car from boost surge and DAM dropped to 5
tested the stock solenoid with 11V battery it clicked / opened and closed when blew threw it...

What we also discovered was that those 1/10 clickers were actually followed to a UTEC ECU by turbosXS... that is currently unplugged And we are back hooked up to factory ECU
At first I ran 7lbs boost “wastegate pressure assuming... Now I’m steady 9... most importantly my DAM has stayed at 16 ??

I reflashed the ECU after hooking back up to stock
Stage 2 93 map notes call for 17lbs...
My concern is I have a hyper flow Intake followed by a FMIC hyperflow
3Inch TBE with up pipe that’s all catless.... I know I’ll need a tune since Cobb stage 2 includes a catted down pipe...

Any ideas on where to see where I’m only pulling 9lbs??
Thanks guys
 

·
Super Moderator
Joined
·
10,884 Posts
Dude. I have no idea. This car sounds like a train wreck. Maybe someone else may have some ideas but I would take it to a performance shop and have it unborked and stop driving it completely.

It sounds to me like you are on spring pressure, however with more and more mods being listed as this goes I'm not going to venture a guess as to what it is.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #15 ·

·
Super Moderator
Joined
·
10,884 Posts
Your waste gate should only open enough to maintain target boost
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #17 ·
Hmmm thanks XJ any idea on why it’s having a horrible LAG... as you see in log when I WOT it builds awfuly and doesn’t punch back into seat feeling....

My concern is possibly because I’m running a stage 2 map from Cobb OTS and running a TBE / uppipe all catless so I knew this wasn’t going to run accordingly since Cobb calls for catted DP / there Air intake..
I figured I would get boost Spike/ surge but tbh it holds GREAT... it just takes her a few seconds to get to peak... lol I plan on getting pro tune in a month I just wanted to diagnose to make sure it is possibly my tune or if this could be another occurrence

Thanks for the input from everyone since post 1 really appreciate it!!
 

·
Super Moderator
Joined
·
10,884 Posts
I can't speak to the tuning for the older vehicles sadly. You could have an exhaust leak or even boost leak
 
1 - 18 of 18 Posts
Top